some tooltips wrap unnecessarily

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Depends on: 1 bug, {regression, testcase})

Trunk
x86
Mac OS X
regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Created attachment 266985 [details]
testcase

Steps to reproduce:
1. Hover over a link whose title attribute is "Primary source".

Result: Wrapped tooltip with extra space at the right.

Expected: One-line tooltip.
Flags: blocking-firefox3?
Can you attach a screen shot? I can't reproduce on Windows, but this is probably a dupe of bug 378846.
(Reporter)

Comment 2

11 years ago
Created attachment 266987 [details]
screenshot
It also WFM in SM1.1.x and FF2.0.0.x on Windows.
I remember seeing a bit of weirdness on the Mac when I was testing the Firefox multi-line patch. I guess it's probably related to pop-ups, fonts, or something else that's Mac specific.
Gavin, do you think this depends on bug 357337? There's a feeling that we're not going to touch the reflow branch again, which means that we might not be able to block on this one ... 
Actually, it's not serious enough to block on anyway, though it is wanted ...
Flags: blocking-firefox3? → blocking-firefox3-
Whiteboard: [wanted-firefox3]
(In reply to comment #5)
> Gavin, do you think this depends on bug 357337? There's a feeling that we're
> not going to touch the reflow branch again, which means that we might not be
> able to block on this one ... 

Bug 357337 has a bad summary. It was originally filed to remove a sizing hack from the front-end tooltip code after the reflow branch landed. Then it was discovered that the reflow branch didn't fix the problem, and that the hack was still needed. The testcase in that bug shows the current problem. I'll talk to Ctho about fixing the summary. We should retest this if bug 378846 is fixed.
Depends on: 357337
Summary: A tooltip with the text "Primary source" wraps unnecessarily → some tooltips wrap unnecessarily [mac only?]
I don't know if I can do anything with bug 378846.  I spent a long time figuring out the current hack and tested it quite a bit (though since I started looking, I have noticed a few cases where the sizing is still wrong with the hack).

This is definitely not mac-only.
Summary: some tooltips wrap unnecessarily [mac only?] → some tooltips wrap unnecessarily
Flags: wanted-firefox3+
Whiteboard: [wanted-firefox3]

Comment 9

9 years ago
Jesse, do you still see this?

testcase WFM. And bug 378846. But bug 228673 testcase fails.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090617 Minefield/3.6a1pre
(Reporter)

Comment 10

9 years ago
WFM :)

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090622 Firefox/3.6a1pre
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.