all add-ons shown as updated today when browsing

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
--
major
RESOLVED FIXED
11 years ago
2 years ago

People

(Reporter: Eric Moore, Assigned: fligtar)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: 

https://addons.mozilla.org/en-US/thunderbird/browse/type:2 

If I click on "more..." underneath "New and Updated" to list all of the updated Thunderbird themes it falsely claims all of them were updated today (June 2, 2007). For example it displays:

Walnut for Thunderbird 1.5 and 2.0
by Alfred Kayser
Walnut for Thunderbird 1.5, 2.0.
Version 1.7.18 — June 2, 2007

yet if I click on the theme https://addons.mozilla.org/en-US/thunderbird/addon/1495 shows it was actually added May 29, 2007. 

It even lists Plastikthunder Crystal SVG 1.0 beta Thunderbird: 0.8 – 0.9+ as being updated June 2, 2007. That theme is so obsolete I don't understand why its still listed. I'm surprised the web site doesn't have some sort of sanity check to prevent something that doesn't even support 1.5.x.x from being listed as "new and updated".

The same problem occurs with Firefox. Goto https://addons.mozilla.org/en-US/firefox/browse/type:2

New and Updated

    * PimpZilla (June 2, 2007)
    * myFireFox (June 2, 2007)
    * The OFFICIAL Washington Capitals NHL Theme (June 2, 2007)
    * macfox II graphite (June 2, 2007)
    * macfox II (June 2, 2007)


More... 

yet PimpZilla 3.49 is actually dated May 29, 2007 

Reproducible: Always

Comment 1

11 years ago
This is actually intended behavior: Updated means that a new version has been approved by the editors. That this version is actually a few days old goes without saying.

So while it has been in the queue for three days, you couldn't see it until now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

11 years ago
Please read the bug report again. 

Are you seriously claiming that there is a new release of "Plastikthunder Crystal SVG 1.0 beta for Thunderbird: 0.8 – 0.9+"? What good is a "new and updated" category if every time you update a few themes you list EVERY SINGLE THEME as new and updated?

https://addons.mozilla.org/en-US/thunderbird/addon/419 states Plastikthunder Crystal SVG was released December 12, 2004 . The "new and updated" list states it was released June 2, 2007. Thats a discrepancy of two and a half years, not three days.

By the way, http://forums.mozillazine.org/viewtopic.php?p=2909241#2909241 is a mozillaZine thread where somebody else has the same complaint. 

"Every extension on 36 pages is dated June 2, 2007. This masks spotting newly introduced and newly updated extensions. I would prefer the former practice of dating the extension with the latest day it was introduced or changed.

The same dating scheme is also now used in the Firefox extension list. Why date them at all if there is null real information conveyed?"
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

11 years ago
(In reply to comment #1)
> This is actually intended behavior: Updated means that a new version has been
> approved by the editors. That this version is actually a few days old goes
> without saying.
> 
> So while it has been in the queue for three days, you couldn't see it until
> now.
> 

I really cannot believe that you have properly understood the bug report.

Currently, in those particular listings, ->->->ALL<-<-<- (= every single one) themes and extensions show a last updated date of Jun 2, 2007.

Are you suggesting that every single one of them has been updated today? Are you going to say that they were all re-approved today, which had the effect of wiping out the properly informative content of that field?

If some administrative operation has been carried out which has resulted in that field being updated for every single add-on then the fact that is possible renders the field utterly meaningless in the context of a user information display. From our point of view the 'last updated' field should not be affected by purely AMO bulk administrative operations. It should relate to the ad-on itself and/or associated text content (not format).

I see that, while I was composing my comment, the originator has re-opened this bug - and quite right too. You may be busy but "invalid" is an awfully rude and dismissive word to use where you have, unthinkingly, not even seen the significance of the description which was provided.

Please will someone who understands the term 'user oriented' address this bug as soon as possible? It affects every single person who goes to those lists for information.

Comment 4

11 years ago
In support of comments 2 and 3 I support the request:

"Please will someone who understands the term 'user oriented' address this bug
as soon as possible? It affects every single person who goes to those lists for
information."

I have been annoyed in the past when some extensions were updated daily by excessive attention seekers, but at least the rest of the 'new and updated extensions' were substantively changed from their last posting. Today there are some 2296 Firefox extensions and 356 Thunderbird extensions listed and all are dated June 2, 2007--get real as soon as possible please.
(Assignee)

Comment 5

11 years ago
(In reply to comment #3)
> Please will someone who understands the term 'user oriented' address this bug
> as soon as possible?

That tone definitely isn't going to help this issue get fixed any faster.

I suspect I caused this when I made this change:
http://viewvc.svn.mozilla.org/vc/addons/trunk/site/app/models/addon.php?r1=4207&r2=4206&pathrev=4207

I was getting PHP notices saying that 'File' wasn't a key for that array in browse pages and anywhere else that code was used. I printed the array and found that there isn't a 'File' key, only a '0' key with the datestatuschanged, so I fixed it and it went away. I don't know how it worked at all before.

After I made this change, I did check to make sure that the dates were showing up in the newest sort and that the most recent date was on top. I didn't think to check if all the dates for all the add-ons were somehow the same.

Severity: normal → major
Status: UNCONFIRMED → NEW
Component: Add-ons → Public Pages
Ever confirmed: true
OS: Windows XP → All
QA Contact: add-ons → web-ui
Hardware: PC → All
Summary: all mozilla addon themes for Thunderbird and Firefox listed as new → all add-ons shown as updated today when browsing
Version: unspecified → 3.0

Comment 6

11 years ago
Yeah, I misinterpreted the original post, apologies. I assumed the issue was the difference between update timestamp and approval timestamp, therefore I marked it invalid, which was wrong.

Yet I agree with fligtar: Calling me an idiot (no matter what term you choose) won't get you any further. People make mistakes (probably even *you* have, before, I know that's surprising) so please stay professional about bugs. In fact, if we didn't make any mistakes, we wouldn't need bugzilla. Ever.

Comment 7

11 years ago
In response to comments #5 and 6, Thank you Justin, for your effort and attention to this matter. 

I think comment #1 missing the point was the problem, not the exasperation it
engendered, but if feelings were bruised that is unfortunate. I have had nightmare experiences with tech support personnel not getting the point--I once asked for help when Windows became corrupted and the mouse and keyboard wouldn't work and was repeatedly told to do things with the keyboard by the professional at the tech support number. It is a collateral consequence of making mistakes that one may engender an emotional reaction by the person frustrated by the misunderstanding. It is also professional to expect and discount such reactions when deciding it is appropriate to admit fault.

I hope you can rectify this bug so that when I make my daily perusal of the new
and updated extensions I can see if there is a new idea I want to incorporate
into my personal iteration of Thunderbird or Firefox.

To you and the others building Firefox and Thunderbird, thank you for these
fine gifts you have provided.

Comment 8

11 years ago
(In reply to comment #5)
> (In reply to comment #3)
> > Please will someone who understands the term 'user oriented' address this bug
> > as soon as possible?
> 
> That tone definitely isn't going to help this issue get fixed any faster.
> 
"That tone" quite simply reflected a proper and justified desire that the next assessment of the report would be made by someone who would take the trouble to look at it seriously within a frame that included an attempt to encounter the situation as would end users. That the person would originally closed the bug had not done so was obvious in their brusque dismissal of the problem.

It is actually correct to freely express such requests, together with the implied judgement of such situations, in proper pursuit of the improved treatment of end users. You appear believe that such freedom of belief and (extremely brief) speech should be suppressed by some kind of inverted appeal to public standards of good behaviour. Where does that lead, I wonder?

Comment 9

11 years ago
(In reply to comment #6)
> Yeah, I misinterpreted the original post, apologies. I assumed the issue was
> the difference between update timestamp and approval timestamp, therefore I
> marked it invalid, which was wrong.

That first paragraph earned you some immediate respect.

(In reply to comment #6)
> Yet I agree with fligtar: Calling me an idiot (no matter what term you choose)
> won't get you any further. People make mistakes (probably even *you* have,
> before, I know that's surprising) so please stay professional about bugs. In
> fact, if we didn't make any mistakes, we wouldn't need bugzilla. Ever.

However, that second was unworthy. Nowhere did I mention or imply the word "idiot". What I said was '"invalid" is an awfully rude and dismissive word to use where you have, unthinkingly, not even seen the significance of the description which was provided'. I think you have, like fligtar, inverted the situation. You had just closed a valid bug as "invalid". In effect, you, actually, had called the originator an idiot. Then you and fligtar object when someone points that out?

Yes, I've certainly made plenty of mistakes and always felt very contrite and angry with myself whether I detected them first or someone else did. However when someone reported a problem, originating possibly with me, possibly with someone else, I always knew the reporter was right until I discovered they weren't. I also knew, until I discovered otherwise, that I was the cause, just as I knew that everyone else involved was the cause. That way, "closed, invalid" was not really on the menu.

It is true that everyone makes mistakes. It is those mistakes against which one must defend, not against criticism of, and arising out of, the mistakes.

I can think of some pretty sick jokes relating to the "I'm only human.." inclusion in error analysis. That bit comes in the planning, not the post mortem. When people *really* start getting abusive, then apart from realising that something seriously upset them, that might be the time to ask them to adjust their approach.
(Assignee)

Updated

11 years ago
Assignee: nobody → fligtar
(Assignee)

Comment 10

11 years ago
Reverted my change and it's fixed on trunk now. This breaks the other area, but it's just API stuff that I can fix when I start working on that again. It looks like it varies based on the joins in the query.
Status: NEW → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED

Comment 11

11 years ago
Thank you again Justin--the web site is now displaying your reverted fix this morning.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.