If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mingw build error in gfxWindowsPlatform.cpp

RESOLVED FIXED

Status

()

Firefox
Build Config
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Bengt-Erik Soderstrom, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Mingw builds were OK for quite a while, but now I get this:

gfxWindowsPlatform.cpp
Building deps for /cygdrive/d/mozilla/mozilla/gfx/thebes/src/gfxWindowsPlatform.
cpp
/cygdrive/d/mozilla/mozilla/build/cygwin-wrapper g++ -mno-cygwin -o gfxWindowsPl
atform.o -c  -DIMPL_THEBES -DMOZILLA_INTERNAL_API -D_IMPL_NS_GFX -D_IMPL_NS_MSG_
BASE -D_IMPL_NS_WIDGET  -DOSTYPE=\"WINNT5.1\" -DOSARCH=WINNT -DBUILD_ID=20070602
00  -I../../../dist/include/cairo -I../../../dist/include/libpixman -I../../../d
ist/include/string -I../../../dist/include/pref -I../../../dist/include/xpcom -I
../../../dist/include/unicharutil -I../../../dist/include   -I../../../dist/incl
ude/thebes -I../../../dist/include/nspr  -DMOZ_PNG_READ -DPNG_NO_MMX_CODE -DMOZ_
PNG_WRITE  -I../../../dist/sdk/include       -fno-rtti -fno-exceptions -Wall -Wc
onversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dt
or-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic -mms-bitfields -pipe
-DNDEBUG -DTRIMMED -O -I../../../dist/include/cairo    -DWINVER=0x501 -D_WIN32_W
INNT=0x501 -D_WIN32_IE=0x0500 -DX_DISPLAY_MISSING=1 -DMOZILLA_VERSION=\"1.9a5pre
\" -DMOZILLA_VERSION_U=1.9a5pre -DHAVE_SNPRINTF=1 -D_WINDOWS=1 -D_WIN32=1 -DWIN3
2=1 -DXP_WIN=1 -DXP_WIN32=1 -DHW_THREADS=1 -DSTDC_HEADERS=1 -DWIN32_LEAN_AND_MEA
N=1 -DNO_X11=1 -D_X86_=1 -DD_INO=d_ino -DSTDC_HEADERS=1 -DHAVE_DIRENT_H=1 -DHAVE
_GETOPT_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_MALLOC_H=1 -DHAVE_LIBM=1
-DNO_X11=1 -DMMAP_MISSES_WRITES=1 -DHAVE_STRERROR=1 -DHAVE_SNPRINTF=1 -DHAVE_MEM
MOVE=1 -DHAVE_RINT=1 -DVA_COPY=va_copy -DHAVE_VA_COPY=1 -DMOZ_EMBEDDING_LEVEL_DE
FAULT=1 -DMOZ_EMBEDDING_LEVEL_BASIC=1 -DMOZ_EMBEDDING_LEVEL_MINIMAL=1 -DMOZ_PHOE
NIX=1 -DMOZ_BUILD_APP=browser -DMOZ_XUL_APP=1 -DMOZ_DEFAULT_TOOLKIT=\"cairo-wind
ows\" -DMOZ_THEBES=1 -DMOZ_CAIRO_GFX=1 -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DO
JI=1 -DIBMBIDI=1 -DMOZ_VIEW_SOURCE=1 -DMOZ_XPINSTALL=1 -DMOZ_JSLOADER=1 -DNS_PRI
NTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_NO_XPCOM_OBSOLETE=1 -DMOZ_XTF=1 -DMOZ_MATHML=
1 -DMOZ_ENABLE_CANVAS=1 -DMOZ_SVG=1 -DMOZ_SVG_FOREIGNOBJECT=1 -DMOZ_UPDATE_CHANN
EL=default -DMOZ_PLACES=1 -DMOZ_PLACES_BOOKMARKS=1 -DMOZ_FEEDS=1 -DMOZ_STORAGE=1
 -DMOZ_SAFE_BROWSING=1 -DMOZ_URL_CLASSIFIER=1 -DMOZ_LOGGING=1 -DHAVE___CXA_DEMAN
GLE=1 -DMOZ_USER_DIR=\"Mozilla\" -DMOZ_STATIC_BUILD=1 -DHAVE_STDINT_H=1 -DHAVE_I
NTTYPES_H=1 -DHAVE_UINT64_T=1 -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DMOZ_RDF=1 -DM
OZ_MORKREADER=1 -DMOZ_DLL_SUFFIX=\".dll\" -DJS_THREADSAFE=1 -DMOZILLA_LOCALE_VER
SION=\"1.9a1\" -DMOZILLA_REGION_VERSION=\"1.9a1\" -DMOZILLA_SKIN_VERSION=\"1.8\"
  -UWIN32_LEAN_AND_MEAN -D_MOZILLA_CONFIG_H_ -DMOZILLA_CLIENT /cygdrive/d/mozill
a/mozilla/gfx/thebes/src/gfxWindowsPlatform.cpp
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsPlatform.cpp: In function `nsresult
ReadCMAPTableFormat12(PRUint8*, PRInt32, FontEntry*)':
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsPlatform.cpp:181: warning: compariso
n between signed and unsigned integer expressions
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsPlatform.cpp: In function `nsresult
ReadCMAPTableFormat4(PRUint8*, PRInt32, FontEntry*)':
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsPlatform.cpp:216: error: comma at en
d of enumerator list
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsPlatform.cpp:252: warning: unused va
riable 'g'
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsPlatform.cpp: In function `nsresult
ReadCMAP(HDC__*, FontEntry*)':
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsPlatform.cpp:294: error: comma at en
d of enumerator list
d:/mozilla/mozilla/gfx/thebes/src/gfxWindowsPlatform.cpp:303: warning: unused va
riable 'version'
make[6]: *** [gfxWindowsPlatform.o] Error 1
make[6]: Leaving directory `/cygdrive/d/mozilla/mozilla/object-mingw/gfx/thebes/
src'
make[5]: *** [libs] Error 2
make[5]: Leaving directory `/cygdrive/d/mozilla/mozilla/object-mingw/gfx/thebes'
make[4]: *** [libs] Error 2
make[4]: Leaving directory `/cygdrive/d/mozilla/mozilla/object-mingw/gfx'
make[3]: *** [libs_tier_gecko] Error 2
make[3]: Leaving directory `/cygdrive/d/mozilla/mozilla/object-mingw'
make[2]: *** [tier_gecko] Error 2
make[2]: Leaving directory `/cygdrive/d/mozilla/mozilla/object-mingw'
make[1]: *** [alldep] Error 2
make[1]: Leaving directory `/cygdrive/d/mozilla/mozilla/object-mingw'
make: *** [alldep] Error 2

It looks like mingw correctly does not like a comma at the end of an enum list.
Other compilers may just give a warning.

Removing those last commas in lines 215 and 293 of ../mozilla/gfx/thebes/src/gfxWindowsPlatform.cpp will fix this bug. 
(Confirmed)
Sorry, I attached a patch in bug 377950 that fixes it (that bug caused it).
Because of the freeze I couldn't check in for a while.
I just checked the patch in, so this should be fixed now.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

11 years ago
OK Martijn, I just noticed it. Everything is fine now.
You need to log in before you can comment on or make changes to this bug.