no extension on jpeg file when downlodaing a picture

RESOLVED DUPLICATE of bug 163458

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 163458
11 years ago
10 years ago

People

(Reporter: Thomas Huxley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a6pre) Gecko/20070602 Minefield/3.0a6pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a6pre) Gecko/20070602 Minefield/3.0a6pre

When saving an image such as a jpeg, when renaming the image while saving, if the extension is removed from the end when renaming, the file loses its extension (even though below the renaming field it says Save As - JPEG picture) and the file has to have its extension added again for the file to work. 

Reproducible: Always

Steps to Reproduce:
1. Right click on a jpeg image and "Save Image As"
2. Rename the image without the extension (.jpeg) and click save

Actual Results:  
No extension on the image, therefore there is no filetype associated with the image for opening. 

Expected Results:  
the image extension is kept with the file if it says "Save As -> JPEG Picture" and not have to add the extension to the picture or keep the extension in the filename when renaming.

Comment 1

11 years ago
Cannot reproduce. Do you have any download-related extensions installed? Does it happen if you start Firefox in safe-mode?
(Reporter)

Comment 2

11 years ago
No download-related extensions installed. Still happens when in safe-mode. Here is a screenshot of what I am doing exactly in case there is any misunderstanding.
http://tinyurl.com/2wdx8b
There is no extension in the file name so when it saves it is as the kind: document, hence I have to add the .jpeg extension for finder to recognise it as a jpeg picture.

Comment 3

11 years ago
This bug is a duplicate of an already filed bug (which has apparently been around for a while. A workaround would be to save the file with the desired extension (be it .jpg or .jpeg).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 163458
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.