Closed Bug 383014 Opened 13 years ago Closed 7 years ago

Clear Recent History doesn't clear the moz_cache_groups table (part of offline cache)

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 674728

People

(Reporter: moco, Assigned: mayhemer)

Details

(Keywords: privacy)

when clearning private data, we aren't clearing the moz_cache_owners table

after trying out <link rel="offline-resource" href="./blah.jpg">, I wanted to make sure that clearing my cache (Tools | Clear Private Data...) would clear the offline cache as well.

It did, but when I inspected index.sqlite (C:\Documents and Settings\<user>\Local Settings\Application Data\Mozilla\Firefox\Profiles\3ga130yk.<foo>\OfflineCache\index.sqlite), I noticed that the moz_cache table was empty, but moz_cache_owners was not.
Keywords: privacy
Summary: when clearning private data, we aren't clearing the moz_cache_owners table → when clearing private data, we aren't clearing the moz_cache_owners table
This is about the code that has no UI per bug 538595, adding dependency.
Blocks: 538595
Summary: when clearing private data, we aren't clearing the moz_cache_owners table → Clear Recent History doesn't clear the moz_cache_owners table (offline cache)
Summary: Clear Recent History doesn't clear the moz_cache_owners table (offline cache) → Clear Recent History doesn't clear the moz_cache_owners table (part of offline cache)
moz_cache_owners table is no longer in the database schema.  Now there is moz_cache_groups and we really don't delete it when removing a host cache or the whole cache.

Updating summary.

I don't think this is in any way related to fixing bug 538595.  This issue can and should be fixed separately.  I'll take care of it.
Assignee: nobody → honzab.moz
Status: NEW → ASSIGNED
Summary: Clear Recent History doesn't clear the moz_cache_owners table (part of offline cache) → Clear Recent History doesn't clear the moz_cache_groups table (part of offline cache)
Blocks: 730424
No longer blocks: 730424
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 674728
You need to log in before you can comment on or make changes to this bug.