Advanced Task Prioritisation & Status Icons

RESOLVED WONTFIX

Status

Calendar
Tasks
--
enhancement
RESOLVED WONTFIX
11 years ago
8 years ago

People

(Reporter: Arik Raffael Funke, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Tablet PC 1.7; .NET CLR 1.0.3705; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: Lightning 0.5 nightly build 2007060103

Currently Lightning supports only basic priorities for tasks. Most advanced time planning concepts however are fundamentally based on the concept of assinging tasks to a 2-D matrix of importent/unimportant vs. urgent/not urgent, possibly of varying degree (c.f. Franklin-Covey). Many people choose to sort their task according to importence as first sorting parameter and with urgency as second.

As this classification of task needs to be reviewed daily to be effective I propose to add a very short text box / drop-down menu at the in front of the task title. Here the user could enter e.g. A1 for a task that is important and urgent or e.g. C1 for a task that is unimportant but urgent.

This concept would allow the user to decide himself how he codes his priorities for sorting and allow for a quick re-adjustment of priorities without having to show the properties dialog for each task individually.


As an additional bonus a small box of symbols to represent various status of the task in the task list would be great, i.e. empty for unassigned, an arrow for forwarded or delegated, a tick/check for completed, cross for deleted, etc.

Layout:
Tasklist
====================================
| A1 |   | Important/Urgent-Testtask
| A3 | ->| Planning Meeting
| C1 | x | Get groceries
|    |   |
|    |   |
======================================

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Unfortunately, the allowed priority values are quite restricted in the ICS standard. This could maybe be done by adding certain categories to tasks and then sorting by category.

Allowing to add categories directly into the task tree might be a valid enhancement request, although its nearly impossible, since <tree> elements don't allow rich content in their columns. This would require bug 405913.

Please resummarize this bug, or close it if using categories is enough, or adding a textbox in the tree is not what you want.
Depends on: 405913
OS: Windows XP → All
Hardware: PC → All
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
No longer depends on: 405913
You need to log in before you can comment on or make changes to this bug.