get_video.htm after restarting a download of a video

RESOLVED DUPLICATE of bug 380046

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 380046
11 years ago
10 years ago

People

(Reporter: Guillermo Moya (MetalS), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.8.1.4) Gecko/20070515 Firefox/2.0  MEGAUPLOAD 1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.8.1.4) Gecko/20070515 Firefox/2.0  MEGAUPLOAD 1.0

When try to download a video from youtube with any extension or an specific web page that help you making that, and for some reason the download crashes and you want to restart your download, the file *.flv is changed with another file with this exact name get_video.htm.

Reproducible: Always

Steps to Reproduce:
1.Download any video from Youtube
2.Cancel the download
3.Restart the download
Actual Results:  
An file .htm

Expected Results:  
An file .flv

Comment 1

11 years ago
Actually, the file I download with the following link saves as "get_video" with no extension. But that's probably by design because youtube isn't supporting this feature of directly downloading flv files, so it doesn't suggest a filename with something like HTTP header Content-Disposition.

http://chi-v228.chi.youtube.com/get_video?video_id=Z2HpAE-QcQA
Whiteboard: [CLOSEME - 06/22]

Comment 2

11 years ago
=> Incomplete. The provided steps don't result in a ".htm" file, but this is also probably something YouTube doesn't directly support.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [CLOSEME - 06/22]

Comment 3

11 years ago
¿Incompleted?

Please, reconsider to take the subjet again.


I've followed the appointed steps using the same link:
 http://chi-v228.chi.youtube.com/get_video?video_id=Z2HpAE-QcQA.

Steps to Reproduce:
1.Download any video from Youtube
[Imagen 01]
http://img383.imageshack.us/img383/4134/flv01yu8.jpg


2.Cancel the download
[Imagen 02]
http://img518.imageshack.us/img518/6228/flv02ua5.jpg


3.At restarting the download, Mozilla Firefox assigns automatically the extension "htm", when at the begining the file's description detects it as "video/flv" (see the first image).

Couldn't it be better to assign the file as "get_video" instead of "get_video.html"?

[Imagen 03]
http://img49.imageshack.us/img49/1465/flv03qa0.jpg

[Imagen 04]
http://img383.imageshack.us/img383/293/flv04vu8.jpg

[Imagen 05]
http://img49.imageshack.us/img49/5375/flv05as0.jpg



Mozilla/5.0 (X11; U; Linux i686; es-AR; rv:1.8.1.5) Gecko/2007071812 Firefox/2.0.0.5 (Ubuntu-feisty)

Updated

11 years ago
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 380046
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.