Last Comment Bug 383125 - Use breakpad for SeaMonkey trunk
: Use breakpad for SeaMonkey trunk
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: seamonkey2.0a1
Assigned To: Robert Kaiser (not working on stability any more)
:
Mentors:
: 408456 (view as bug list)
Depends on: 380906 386726 389382
Blocks: 328854 373373
  Show dependency treegraph
 
Reported: 2007-06-04 05:53 PDT by Robert Kaiser (not working on stability any more)
Modified: 2007-12-14 21:23 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Enable breakpad, disable Talkback (3.04 KB, patch)
2007-07-09 09:19 PDT, Robert Kaiser (not working on stability any more)
ted: review+
Details | Diff | Review

Description Robert Kaiser (not working on stability any more) 2007-06-04 05:53:18 PDT
As we finally have new OSS crash reporting technology, we should use it ;-)

SeaMonkey would love to be one of the first testers and adopters of breakpad, esp. as there are problems with Talkback for community builds anyways (see bug 373373) and we had no crash reporting on mac for an even longer time (bug 328854) - so we'd re-gain crash reporting again with that, which sounds like a good idea for trunk :)
Comment 1 Robert Kaiser (not working on stability any more) 2007-06-04 05:55:33 PDT
Also see bug 379396 which is basically the same for Thunderbird
Comment 2 Robert Kaiser (not working on stability any more) 2007-07-08 16:43:13 PDT
OK, it looks like ther only step we still need to go is enabling breakpad and disabling/removing Talkback ;-)
Comment 3 Robert Kaiser (not working on stability any more) 2007-07-09 09:19:51 PDT
Created attachment 271527 [details] [diff] [review]
Enable breakpad, disable Talkback

This enables breakpad for SeaMonkey and removes building Talkback from the two tinderboxen that build it currently.
Comment 4 Ted Mielczarek [:ted.mielczarek] 2007-07-09 10:41:49 PDT
Comment on attachment 271527 [details] [diff] [review]
Enable breakpad, disable Talkback

You know, I forgot to comment, but you should have
#if MOZILLA_OFFICIAL
Enabled=1
#endif so we don't wind up gettting reports from random self builds.
Comment 5 Robert Kaiser (not working on stability any more) 2007-07-09 11:33:05 PDT
Checked in with the ifdef from comment #4
Comment 6 Adam Guthrie 2007-07-09 14:48:38 PDT
You should probably set the MOZ_CRASHREPORTER_DISABLE env. var. on the tinderboxes themselves until bug 379290 gets fixed, otherwise the crash reporter dialog will come up when it crashes and cause problems.
Comment 7 Robert Kaiser (not working on stability any more) 2007-07-25 13:55:54 PDT
(In reply to comment #6)
> You should probably set the MOZ_CRASHREPORTER_DISABLE env. var. on the
> tinderboxes themselves until bug 379290 gets fixed, otherwise the crash
> reporter dialog will come up when it crashes and cause problems.

Actually, what we really want is MOZ_CRASHREPORTER_NO_REPORT, which I learned by breakpad unit tests failing with the other one - but that's done now :)
Comment 8 Reed Loden [:reed] (use needinfo?) 2007-12-14 21:23:42 PST
*** Bug 408456 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.