Firefox browser can not reach URLs after incomplete / slow file download cancelled.

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: junk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; StarBand Version 4.0.0.2; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

If a website fails to serve (or complete) a downloading file after a download session has started, and the user cancels the download session, and then closes the Firefox download dialog window, the browser will be unable to reach any other URLs. Firefox then behaves as if there is no internet connection, except no failed to connect msg will appear. When this happens, opening additional single or multiple firefox windows will also not be able to connect. While this is happening IE (6.0.2800) can be opened and it will function as normal (reaching all URLs), but firefox can not. This condition will continue until the computer is rebooted, then normal Firefox function is again available. The two previous versions (I don't recall the versions used) of firefox I used had this problem also. When this happens zonealarm firewall shows firefox is not trying to access the web, even though firefox bottom frame says "connecting to www.excite.com..." or any other url rquested.

Reproducible: Always

Steps to Reproduce:
1.Start download
2.cancel download
3.Try to go to new URL.
Actual Results:  
Requires reboot to regain firefox function.

Expected Results:  
Fetch the requested page or site. 

P3 700mhz, win 98se, 384 mb ram.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
I don't see this problem. Can you also reproduce this in Firefox's -safe-mode or with a new profile?
http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Folder
(Reporter)

Comment 2

12 years ago
Starting in safe mode had no effect. 

As an additional input I forgot to add originally, other open firefox browsers minimized on the task bar would also stop being able to reach new urls when the current window had a download cancelled and stopped working.

I created a new profile.  This may have cleared the problem as a newly opened firefox browser is now able to reach urls. I tried cancelling a download session in progrees and the browser still functioned. However I will reserve final verdict until I have to cancel a download that the sending site has hung, and firefox was waiting for. This will help determine if firefox stopped responding to the download, rather than the sending site being slow / at fault.

Thanks for the help. I'll post any new info I get.

Best Regards,
Bobby
I tested this bug and was not able to reproduce it.  Since Bobby has reported that he appears to not be experiencing this problem any longer after creating a new profile, it appears to be an issue with his profile.

Please re-open the bug if the problem reappears.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.