mozilla.ps file left in working directory (usually home directory) when I use print preview

RESOLVED DUPLICATE of bug 382169

Status

()

Core
Print Preview
RESOLVED DUPLICATE of bug 382169
11 years ago
11 years ago

People

(Reporter: dolphinling, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a6pre) Gecko/20070602 Minefield/3.0a6pre ID:2007060204 [cairo]

Whenever I use print preview, a file called mozilla.ps is created in my home directory (actually, whatever directory I ran firefox from). It gets left there even after I close firefox, and is basically just an annoyance.

If run from a console, the following is printed:
"/home/dolphinling/mozilla.ps", 12240, 15840
612.000000 792.000000
12240 15840

I'm pretty sure this is a regression, and while I was looking for a regression range for another bug, I think I narrowed this one down to sometime between 2006-04-06 and 2006-08-10 (but I didn't verify that).

Comment 1

11 years ago
http://lxr.mozilla.org/seamonkey/source/widget/src/gtk2/nsDeviceContextSpecG.cpp#431
Here is the code which create the ps file.
I think when you do the print preview, you don't need to do that.
Also the ps file should be a temp file.

Comment 2

11 years ago
This is the same issue as bug 382169 and bug 362357.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 382169
You need to log in before you can comment on or make changes to this bug.