If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

a supported extension is disabled for your protection

RESOLVED INCOMPLETE

Status

Thunderbird
General
RESOLVED INCOMPLETE
11 years ago
10 years ago

People

(Reporter: Eric Moore, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Thunderbird version 2.0.0.0 (20070326)

I've run across several cases where a Thunderbird extension is supported in Thunderbird 2.0, several people in the mozillaZine forums report they have no problem installing it, yet when I install it is disabled, and tools -> addons states:

Requires additional items
Disabled for your protection 

The "More information" link does nothing. Trying to enable it and restarting Thunderbird several times does nothing.

Lately I've seen this with the URL Link 2.01.0 and Show In Out 0.4.1 extensions. It occurs with both 2.0 and version 2.0.0.5pre (20070603) of Thunderbird. I've disabled compatibility checking by setting extensions.checkCompatibility to false. I'm using XP Pro SP2. Both versions of Thunderbird were using the same profile.

https://addons.mozilla.org/en-US/thunderbird/addon/403
https://addons.mozilla.org/en-US/thunderbird/addon/3492
 

Reproducible: Always
(Reporter)

Comment 1

10 years ago
The MIME edit 0.6 and Rainbowpicker 0.5 extensions also causes this problem. I'm currently using 2.0.0.4 and version 2.0.0.5pre (20070617)

https://addons.mozilla.org/en-US/thunderbird/addon/4498 
https://addons.mozilla.org/en-US/thunderbird/addon/1693

However, even though tools -> addons claims MIME edit is disabled, the command was added to the tools menu and it works fine.

Buttons!0.5.3.2 and ImportExportTools 1.2. are also disabled with the same error message, which is new. However, both still work. I re-installed Show In Out and it had the same error message as before in tools -> add-ons, (and I can't set its options) but it added a correspondence and a sort by in/out column.
Version: unspecified → Trunk
This is most likely due to using a non-standard (and broken) theme. If you switch to the default theme does the problem go away?
No response, resolving INCOMPLETE
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.