Crash [@ nsIFrame::GetNextBox] with <xul:listbox> and <xul:listhead>

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: jruderman, Assigned: neil)

Tracking

({crash, regression, testcase})

Trunk
x86
Mac OS X
crash, regression, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
Created attachment 267222 [details]
testcase (crashes Firefox when loaded)

This regressed between 2007-06-03 and 2007-06-04 nightlies, so I think it's a regression from bug 382746 or bug 382899.
(Reporter)

Updated

12 years ago
Severity: normal → critical
(Assignee)

Updated

12 years ago
Duplicate of this bug: 383274
(Assignee)

Comment 2

12 years ago
Created attachment 267285 [details] [diff] [review]
Proposed patch

This needs to be null-checked (c.f. nsGridRowLeafLayout::PopulateBoxSizes).
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #267285 - Flags: superreview?(bzbarsky)
Attachment #267285 - Flags: review?(enndeakin)
Comment on attachment 267285 [details] [diff] [review]
Proposed patch

Sure
Attachment #267285 - Flags: superreview?(bzbarsky) → superreview+

Updated

12 years ago
Attachment #267285 - Flags: review?(enndeakin) → review+
(Assignee)

Comment 4

12 years ago
Fix checked in.
Blocks: 382746
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Flags: in-testsuite?
(Reporter)

Comment 5

11 years ago
Crashtest checked in.
Flags: in-testsuite? → in-testsuite+

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
Crash Signature: [@ nsIFrame::GetNextBox]
You need to log in before you can comment on or make changes to this bug.