Loss of values of input components (components within a html form) when accessing site by https

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: Gerald Holl, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 5-15-2010])

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

The latest Firefox Release 2.0.0.4 seems to have problems when accessing sites by https that contain html form elements.
We have a webapp which is built with JSF 1.2, Tomcat 6.0.13.
If I access our app by https and enter values in the fields and select elements from a combo and the submit the form, sometimes it happens that the value of an input field is empty although I entered the value. Another example is that the selected value of a combo isn't being submitted to the server.

The whole stuff works most of the time but if I submit the form many times (maybe 30 times or so), the value of e. g. an input field is empty. The submit before that one however contained some text in the input field.

This issue only occurs if I access the page by https, if I try it by http everything works fine.

For testing purposes I installed Firefox 1.5.0.4 where everything works fine - no input field loss, even with https.

Reproducible: Sometimes

Steps to Reproduce:
1. Submit the form (sometimes 3x and sometimes > 30x)
(Reporter)

Comment 1

11 years ago
Are there any comments on this bug? It's still present in the latest Firefox Release.
If some more debugging infos are needed please let me know.
(Reporter)

Comment 2

11 years ago
This bug seems to be caused by an invalid character encoding.
The web server serves the pages as ISO-8859-1 but if I enter german Umlauts (e. g. ö, ä) Firefox loses the values of that input components. This doesn't happen every time but it's reproduceable.
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Whiteboard: [CLOSEME 5-15-2010]
Version: unspecified → 2.0 Branch
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.