When downloading two files simultaneously, download start window disappears for the first file

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
--
minor
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Seyed Amin Mirzaei, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

When downloading two or more files simultaneously, if you wait enough for the other download start windows to appear, and answer one of them, the other windows disappear until you change focus on another window (other than the Firefox main window) and change it back to the Firefox window (e.g. by pressing Alt+Tab).

Reproducible: Always

Steps to Reproduce:
1. Open the Download Manager window
2. Start two downloads (start the second one before the first download window (What to do ...) appears)
3. Answer the second download (e.g. Choose "Save to...")

Actual Results:  
The first download window is gone.

Expected Results:  
The first download window should be there after dismissing the second window.

Additionally, perform these steps after the last step (3):
1. Click on Start menu, or Desktop
2. Click on the Firefox main window
Now the first window appears.
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch

Comment 1

11 years ago
i have seen this problem many times so i can confirm this, at least on branch

instead cannot reproduce on Trunk, could you try with a current nightly build?
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> i have seen this problem many times so i can confirm this, at least on branch
> 
> instead cannot reproduce on Trunk, could you try with a current nightly build?
> 

/*
An example of this bug could be found here (with instructions): http://khorshid.ut.ac.ir/~amin/firefox
*/

I've tried Minefield (3.0a5pre - 3.0a7pre), no problem. But 2.0.0.5pre still has this problem.
Instead, another problem appears in Minefield. When you have two "Openning X" windows, pressing OK button with "Save to Disk" selected, opens a modal dialog (The "Openning X" window is NOT modal itself). But if you have two "Openning X" windows, and press the OK button on one of them, the Browse window is only modal to the main window, not to the other "Openning X" window. This can cause a problem: You can press the OK button on the other "Openning X" window before dismissing the browse window, and that will cause another browse window to appear. Now you have 2 browse windows that are modal to the main window. Now dismiss the FIRST BROWSE WINDOW (not the first download's browse window!). The second browse window loses it's modality! The strange thing is if you dismiss the second browse window first, this will not happen.
This doesn't happen in Firefox 2.x, because the second "Openning X" window's OK button remains disabled until you dismiss the browse window. Thus you can't open another browse window.
Should I report this bug as a new one?

Comment 3

11 years ago
yes please, always open bugs in separate reports, so they can be investigated

Comment 4

10 years ago
per comment #2 this does not happen in Trunk, so marking WFM per decision to give Branch only security and important fixes

So, this is a branch only problem

If you do not have opened the second report, please check that the problem have not already been reported, and open a new bug report with Trunk as version
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.