images with same filename rendered from cache incorrectly

RESOLVED DUPLICATE of bug 404922

Status

RESOLVED DUPLICATE of bug 404922
12 years ago
9 years ago

People

(Reporter: brianmauter, Unassigned)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupeme?)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: version 2.0.0.0 (20070326)

Suppose you have one.png and two.png.  If I drag one.png to the compose window, TB renders it fine.  Now delete one.png and either send the first message or close the compose window.  Start a new message, rename two.png to one.png and drag it to the compose window.  One.png will render instead of two.png.

Why would anyone do this?  Think of screenshots in OS X.  When you take a screenshot, OS X saves it to a file called "Picture 1.png".  If I delete that file and do another screenshot, I again get a new file called "Picture 1.png".  If I have already sent the first "Picture 1.png" in an email and later during the day send another "Picture 1.png", the first renders in my compose window.

I tried this on a Windows computer too.  The version of TB there was 1.5.0.12 (20070509).

Reproducible: Always

Steps to Reproduce:
please see details
Actual Results:  
please see details

Expected Results:  
please see details

No extra addons or themes are being used.
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0

Updated

11 years ago
Depends on: 450738

Comment 1

10 years ago
I agree. I have hated this ever since I started using Thunderbird. I constantly encounter it because I'm constantly resizing photos and saving them under the same name.

I'm on Vista.

Comment 2

10 years ago
This is still reproducible on trunk with Mozilla/5.0 (Windows; U; Windows
NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081027 Shredder/3.0b1pre. This may
however be caused by the same mechanism (thus this bug being potentially a duplicate, or at least related to) as described in bug 404922.
Whiteboard: dupeme?

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404922
You need to log in before you can comment on or make changes to this bug.