Advanced search ignores conditions after "has attachments" condition, for example attachment status is has attachment AND date is after xx disregards date criteria (other way around works)

RESOLVED WORKSFORME

Status

P2
major
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: seb, Assigned: Bienvenu)

Tracking

({regression})

1.8 Branch
Thunderbird 3.0b1
regression
Bug Flags:
blocking-thunderbird3 -
wanted-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: version 2.0.0.0 (20070326)

If I search a folder with "Match all the following" and with "Attachment Status is Has Attachments" as the first criteria and "Date is after 4/6/2007" as the second, the search result includes all the emails with attachments in the folder not just those date after 4/6/2007. If I reverse the order of the search criteria, the search works OK.

Reproducible: Always

Steps to Reproduce:
Explained in details above.

Comment 1

11 years ago
Confirmed on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a6pre) Gecko/20070607 Thunderbird/3.0a1pre ID:2007060703 [cairo]

Updating summary...
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: The Search System has a specific bug → search for attachment status is has attachment AND date is after xx disregards date criteria (other way around works)
Duplicate of this bug: 391332

Comment 3

11 years ago
Note that the other bug report more accurately identified that the issue is with the "Attachment Status" rule (as opposed to it in combination with a particular additional rule).

The bug is therefore that *any* rule(s) appearing after an "Attachment Status" rule will be ignored (while rules appearing before an "Attachment Status" rule will function as expected).

Comment 4

11 years ago
Another update:

I just checked and this bug also affects Saved Searches in the same manner.

I'm assuming it's possible that it also affects Message Filters, but I haven't been able to verify that yet...

Comment 5

11 years ago
regression, works in TB 1.5.0.4, if my test with 1.5 was correct.  
failure in SM goes back to at least rv:1.8.1.2pre Gecko/20070119 

improved summary.
Severity: normal → major
Keywords: regression
Summary: search for attachment status is has attachment AND date is after xx disregards date criteria (other way around works) → Advanced search ignores conditions after "has attachments" condition, for example attachment status is has attachment AND date is after xx disregards date criteria (other way around works)
Version: unspecified → 2.0

Updated

11 years ago
Duplicate of this bug: 368953

Comment 7

11 years ago
xref bug 382520 (possibly dupe but it's hard to say)

Comment 8

11 years ago
Magnus in  comment #7
> xref bug 382520 (possibly dupe but it's hard to say)

... only if 382520 is a regression, i.e. if it worked in v1.5

behavior far more odd than just the current location of Attachment status in the list.  I ran a search with 4 condition lines and attachment status in position #2, and then moved it to last position #4 and the search results were the same - more hits than expected, as if it were still in position #2. 

But I also ran a same search later where I moved it from last (got correct # hits) to second and go the same # hits - got correct # hits. 

requesting blocking TB3 - regression.
Flags: blocking-thunderbird3?

Comment 9

10 years ago
The problem appears to be that the search term parser does not consume the value from the input stream for this condition, and does not skip to the close parenthesis.  

E.g., when parsing "(has attachment status,is,true\)", the "true" is not read, and the instream pointer is not advanced, so the next condition is not recognised.

Updated

10 years ago
Flags: wanted-thunderbird3+
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3-
(Assignee)

Comment 10

10 years ago
taking
Assignee: nobody → bienvenu
Priority: -- → P2
Target Milestone: --- → Thunderbird 3.0b2

Comment 11

10 years ago
In a virtual folder, the "custom view" named "has attachments" gives wrong results and catches messages outside of the saved search. A confirmation of the bug.
win tb 2.0.0.17 locale FR

Comment 12

10 years ago
bienvenu in comment #10
> taking
Assignee: bienvenu → nobody
Component: General → Search
Product: Thunderbird → MailNews Core
QA Contact: general → search
Version: 2.0 → 1.8 Branch

Comment 13

10 years ago
fixing assignment to bienvenu@nventure.com
Assignee: nobody → bienvenu
(Assignee)

Comment 14

9 years ago
this wfm - I suspect someone (rkent?) fixed this for 3.0
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.