IMAP: long Ja subject is not displayed correctly on the window title.

VERIFIED DUPLICATE of bug 58114

Status

P3
normal
VERIFIED DUPLICATE of bug 58114
19 years ago
10 years ago

People

(Reporter: ji, Assigned: nhottanscp)

Tracking

({intl})

Trunk
All
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [RTM-])

Attachments

(3 attachments)

(Reporter)

Description

19 years ago
Build: Win32 2000-05-05-13 comm build

With IMAP account, the long Japanse subject is not displayed corretly in the 
thread pane and window title. In the thread pane, the subject has some extra 
question marks in it. The window title has some extra dots in it.
 
Will attach a testing folder.

To reproduce the problem, you can put the folder in your pop mail account
and copy the messages to the IMAP INBOX.
(Reporter)

Comment 1

19 years ago
Created attachment 8364 [details]
testing folder containing several msgs with Ja long subject
(Reporter)

Comment 2

19 years ago
On the linux platform, the behavior is little different. (Before we were unable 
to see the Ja window title on English Red Hat. Now on Japanaese RH6.2 we can see 
tht Ja window title) the behavior is little different:
1. The long Ja subject is displayed alright on the thread pane.
2. The Ja long subject is displayed incorrectly in the window title only in some 
conditions,
   for example, when the subject is a long string of two-byte katakana with
   ascii chars ending like the last two msgs in the testing folder.
3. No difference between IMAP account and POP account. On Windows NT, this 
   problem only exists with IMAP account.
(Assignee)

Comment 3

19 years ago
Please also attach a screen shot.
(Assignee)

Comment 4

19 years ago
Also, could you attach the data zipped?
(Reporter)

Comment 5

19 years ago
Can't attach the screen shot to the report. Bugzilla can't recognize jpg type
even I checked on right one. Please see the screen shot at:
http://rocknroll/users/ji/publish/seamonkey/bug38340/longsubject1.jpg
(Reporter)

Comment 6

19 years ago
Created attachment 8366 [details]
Zipped testing folder
(Assignee)

Comment 7

19 years ago
Created attachment 8367 [details]
screen shot
(Assignee)

Comment 8

19 years ago
I think this is a dup of 38192.

*** This bug has been marked as a duplicate of 38192 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

19 years ago
With a long subject that I actually typed into the subject field instead of 
copy/paste, I still can see the problem. Since we have another problem with IME
in the subject field (bug 38319), I'm not sure if this problem is caused by
the same reason. Will Verify this later when 38319 gets fixed.

Comment 10

19 years ago
QA contact to ji.
QA Contact: momoi → ji
(Reporter)

Comment 11

19 years ago
Verified as such based on Naoki's explanation.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 12

19 years ago
This was not a dup of 38192, reopen.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 13

19 years ago
This is fixed in today's build (but 38192 is not).
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

19 years ago
Verified with today's Win32 and linux build.
It's fixed.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 15

19 years ago
It was found that this is a generic line continuation handling problem for IMAP.
So this is a dup of 38192. My last change fixed a partial problem described in 
this bug. But the real fix should not be inside MIME decoder. I removed my 
change and this bug has to be reopened. I will mark this as 38192.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 16

19 years ago

*** This bug has been marked as a duplicate of 38192 ***
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 17

18 years ago
verified as a dup.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 18

18 years ago
With win32 2000200509-MN6 build, the long subject has extra dots inserted in the window title again.
Linux and Mac branch build doesn't have this problem.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 19

18 years ago
Nominating for rtm.
Keywords: rtm
(Reporter)

Comment 20

18 years ago
Japanese long subject is displayed alright on the thread pane. Changed the original summary accordingly.
Summary: IMAP: long Ja subject is not displayed correctly both on the thread pane and on the window title. → IMAP: long Ja subject is not displayed correctly on the window title.
(Assignee)

Comment 21

18 years ago
I think window title for message has been blank for a while so we did not see
this problem.
Status: REOPENED → ASSIGNED
(Reporter)

Comment 22

18 years ago
Yes, bug 50682 for window title just got fixed on today's builds.

Comment 23

18 years ago
Ftang - Please marek this one as [RTM Need Info].

Changing status to P2.

Updated

18 years ago
Blocks: 55824

Updated

18 years ago
Priority: P3 → P2

Updated

18 years ago
Whiteboard: [RTM Need Info]
(Assignee)

Comment 24

18 years ago
No patch available currently.
There is a problem in our line unfolding code but we decided not to change it
for this release. For thread pane, tabs are removed before sent to RDF. We might
be able to do similar for window title.

Comment 25

18 years ago
I really don't think this is a P2 nor P1. I think this is a P3. Mark it as rtm-
Priority: P2 → P3
Whiteboard: [RTM Need Info] → [RTM-]
(Assignee)

Comment 26

18 years ago
*** Bug 38192 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Target Milestone: --- → M26

Comment 27

18 years ago
Adding Cindy to cc: list.
(Assignee)

Updated

18 years ago
Depends on: 58114
Target Milestone: M26 → M23

Updated

18 years ago
Keywords: intl, nsbeta1
(Assignee)

Comment 28

18 years ago
Marking as a dup of 58114.

*** This bug has been marked as a duplicate of 58114 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 29

18 years ago
nhotta: are you positive this is a duplicate of bug 58114? If so, then please
verify, else reopen. Thanks!
(Assignee)

Comment 30

18 years ago
verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.