just doesn't work with Firefox 2.0.0.4

RESOLVED INVALID

Status

Other Applications
Venkman JS Debugger
--
critical
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Benoit Blais, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: JavaScript Debugger 0.9.87

The first time it is launched, it tries tries to start but hangs before getting even its window's title bar.  Some options works though even the display is all messed up.  Once closed through "File | Exit", Firefox dies and therefore, there is no way to launch it again (even it's purposeless anyway).  This might be a Firefox 2.0.0.4 bug though, since strange problems have been seen with "Better GMail" addon too.

Reproducible: Always

Steps to Reproduce:
1. Open Javascript Debugger with Firefox 2.0.0.4 on Windows XP SP2
2. Have fun...
3. Reboot your computer if you want to try again...
Actual Results:  
see description

Expected Results:  
Debugging a web page, since this occurs on any page, even the simple google.com one

Firefox problem ?  Good to look at in case you don't want to spend too much time with this problem...

Comment 1

11 years ago
File > Exit does what it says it does, it *exits*. It's perfectly normal that Firefox then "dies" - it's called "exiting", and it's what you told it to do.

And you're going to have to do better than "the display is all messed up" in your description, or I'm marking this INVALID, especially since it wfm.

Comment 2

11 years ago
A screenshot of the messed up display would be a good start.

Also, if you do File > Exit in *Firefox* it closes all windows, just like if you do File > Exit in the JavaScript Debugger. (There may be some cases this isn't always the same operation, but please keep one issue to one bug.)
(Reporter)

Comment 3

11 years ago
Here is a screenshot : http://www.kingdom.cjb.net/jsdebug_1.jpg

In my own point of view, I believed that exiting would exit from the debugger, but if you tell me it's okay to close firefox as well, it's okay, now I know it...  

msg to Gijs : I never sent this message to f*ck with anybody, but just to let you know there was something wrong going on.  If you like people collaborating that much, get a new job poor you.  Being able to align a couple of line of code seems easy for both of us.  Being able to talk without spitting seems kinda hard for you though...

Comment 4

11 years ago
Thanks for the screenshot - a thousand words and all that. :)

It looks like what is going on is that the JavaScript Debugger window is not getting some standard parts of the browser theme applieds to it - namely, the window background

Judging from what I can see (toolbar and the "bubbles"), it looks to me like you are not using the standard Firefox theme. Is that the case? If so, could you try switching Firefox back to the default and see if things work better that way? (Knowing which theme it is and where to get it would be great.)
(Reporter)

Comment 5

11 years ago
You were absolutely right
I'm real shy now, since I didn't even remember I was using a theme since this theme is packed in my firefox bundle...  This said, once the theme has been removed, everything went back to normal : the debugger runs fine and no more hassle occurs.  Totally sorry about being such an idiot while I was trying to help.....
The theme was Metal Lion Vista - 1.6.7 from https://addons.mozilla.org/en-US/firefox/addon/4626

A thousand thanks to you being so patient James.  I'll double check myself before being such a lamer...

Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Comment 6

11 years ago
(In reply to comment #3)
> msg to Gijs : I never sent this message to f*ck with anybody, but just to let
> you know there was something wrong going on.  If you like people collaborating
> that much, get a new job poor you.  Being able to align a couple of line of
> code seems easy for both of us.  Being able to talk without spitting seems
> kinda hard for you though...
> 

My apologies if I was harsh. It's just that your original bugreport wasn't all that informative, and you didn't seem all that clueful when describing how firefox "dies" when you use the Exit menu item. Additionally "even it's purposeless anyway" and "Reboot your computer if you want to try again..." are major "FUD" triggers for me.

Finally, I was assuming most of the problems you described about starting it again would actually be bug 338581 (but I couldn't tell from your wording), which I've grown bored of because everyone keeps reporting it when it's prominently documented on AMO (https://addons.mozilla.org/nl/firefox/addon/216).

See also https://bugzilla.mozilla.org/page.cgi?id=bug-writing.html, and note that your original report failed to meet the two criteria listed at the top (as "the display was messed up" is not specific, and as said I couldn't reproduce your report).

So in closing, sorry if I came off like a jerk, and when/if you file other bugreports, please keep the above in mind, as it'll help you get help, and help us fix things ASAP. :-)
You need to log in before you can comment on or make changes to this bug.