Investigate how percent-complete / task status should be handled

NEW
Unassigned

Status

Calendar
Tasks
11 years ago
6 years ago

People

(Reporter: Robert Brand, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4pre) Gecko/20070606 Sunbird/0.5

If you set a task's status to "In Process", e.g. "50%", but later set it back to "Not specified", the tooltip still shows the previously specified status information when hovering the task item in the task list.

Reproducible: Always

Steps to Reproduce:
1. Create a task, set status to "In Process" + "50%".
2. Hover task in task list: the tooltip shows "% Completed: 50%".
3. Edit task, set status back to "Not specified".
Actual Results:  
When hovering task in task list, the tooltip still says "% Completed: 50%".

Expected Results:  
Tooltip shouldn't contain status information anymore or at least not display an incorrect (revised) information.
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4pre) Gecko/20070524 Sunbird/0.5.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

10 years ago
Still valid with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13pre) Gecko/20080215 Calendar/0.8pre
(Reporter)

Comment 3

9 years ago
Still valid with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090131 Calendar/1.0pre
(Reporter)

Comment 4

8 years ago
Created attachment 436283 [details] [diff] [review]
[checked in] Proposed Patch, v1

I tried to look into this myself. As usual I'm not really sure, but:
It seems that in mouseoverPreviews.js we should not only check for percentComplete being unequal 0 or 100, but also for the task's status not being "null", which would be the result of a status reset to "Not specified".
At least this solution seems to work for me using Sunbird 1.0b2pre or Lightning 1.1a1pre.
Attachment #436283 - Flags: review?
(Reporter)

Comment 5

8 years ago
Comment on attachment 436283 [details] [diff] [review]
[checked in] Proposed Patch, v1

Ups, sorry, now trying to really request review.
Attachment #436283 - Flags: review? → review?(philipp)
(In reply to comment #4)
> Created an attachment (id=436283) [details]
> Proposed Patch, v1

I thought the percentage is independent from the status.
Assignee: nobody → mozrob
Status: NEW → ASSIGNED
OS: Windows XP → All
Hardware: x86 → All
Summary: Task list (Sunbird): tooltip of task not updated after setting status back to "Not specified" → Task list: Tooltip of task not updated after setting status back to "Not specified"
Comment on attachment 436283 [details] [diff] [review]
[checked in] Proposed Patch, v1

rfc5545 makes no specific note if the STATUS needs to conform to the PERCENT-COMPLETE. Therefore we can theoretically have tasks that don't have a status specified, but do have a percent complete.

On the contrary, in our UI when we set a task to not specified, then we don't allow entering a percent complete. If we make the dialog remove the percent complete when setting to not specified, then this might mean dataloss in some systems.

This patch would surely be a good workaround for now (since percent-complete + status not specified is probably an edge case), but we should find a long term solution soon too.

Robert, would you be willing to look into this?

(Robert, do you have checkin access? If not, please set checkin-needed)
Attachment #436283 - Flags: review?(philipp) → review+
(Reporter)

Comment 8

8 years ago
(In reply to comment #7)
> This patch would surely be a good workaround for now (since percent-complete +
> status not specified is probably an edge case), but we should find a long term
> solution soon too.
> 
> Robert, would you be willing to look into this?
I'm sorry, but currently I lack time and I guess also skills for doing this. Shall we reassign to nobody for the moment and if no one steps in I will give it a try during my (far away) summer holidays?
Keywords: checkin-needed
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/75bda9e3e0b3>
-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0b2
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: 1.0b2 → ---
Keeping bug open to fix backend issues
Assignee: mozrob → nobody
Status: REOPENED → NEW
Keywords: checkin-needed
Summary: Task list: Tooltip of task not updated after setting status back to "Not specified" → Investigate how percent-complete / task status should be handled
Attachment #436283 - Attachment description: Proposed Patch, v1 → [checked in] Proposed Patch, v1
You need to log in before you can comment on or make changes to this bug.