custom views based on tags don't work with IMAP accounts

RESOLVED INVALID

Status

Thunderbird
Mail Window Front End
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Eric Moore, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Thunderbird version 2.0.0.5pre (20070606)

Custom views based on one or more tags being present work correctly in local folders or POP accounts, but show nothing in a IMAP account. This problem occurs with both the 2.0 release and the 2.0.0.5pre (20070606) nightly build under XP Pro SP2. The same profile was used for both versions.

Custom views that don't use tags or viewing a message based on selecting a tag (from the Tags list box in the View list box) work.
 
I've tested this with both www.fastmail.fm (a Cyrus IMAP server) , my ISPs Courier IMAP server and a www.aim.com IMAP server. Since I normally use a 1.5 compatible theme (with version checking disabled) I also tested using safe mode to verify the problem was not theme or extension dependent. 

name="all tags"
enabled="yes"
type="1"
condition="OR (\"X-Mozilla-Keys\",contains,forum) OR (\"X-Mozilla-Keys\",contains,FYI)"

user_pref("mailnews.tags.forum.color", "#3333FF");
user_pref("mailnews.tags.forum.tag", "Forum");
user_pref("mailnews.tags.fyi.color", "#FF6600");
user_pref("mailnews.tags.fyi.tag", "FYI");

Reproducible: Always

Comment 1

11 years ago
When I do it I get this, which works:

condition="OR (tag,contains,forum) OR (tag,contains,fyi)"

In the message source, I do not see any X-Mozilla-Keys headers.
(Reporter)

Comment 2

11 years ago
My error. No idea why I tested X-Mozilla-Keys (which doesn't show up in IMAP
headers) instead of just selecting "tags". X-Mozilla-Keys is a custom header I added thats used in the mbox files to store the tags. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.