Closed Bug 383567 Opened 15 years ago Closed 15 years ago

The displayed menu item in a collapsed XUL combo box should have SHOWING state exposed

Categories

(Core :: Disability Access APIs, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 383355

People

(Reporter: ginnchen+exoracle, Assigned: ginnchen+exoracle)

References

(Blocks 1 open bug)

Details

(Keywords: access)

Attachments

(1 file)

Currently, the displayed menu item in a collapsed XUL combo box does not have
SHOWING among its states.  While it can be distinguished by the states of
FOCUSED and SELECTED, including the SHOWING state would mean that the visible
text could be identified in the same fashion as one can do with lists rather
than having to be handled as a "special case."

see also bug 382270
Attached patch patchSplinter Review
BTW: atk will query parent selectable interface and add STATE_SELECTED  if  child is selected.
That's why you can see STATE_SELECTED in accerciser even without this patch.
Attachment #267559 - Flags: review?(aaronleventhal)
Unfortunately I had been working on this already and was seeking r=
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 383355
Attachment #267559 - Flags: review?(aaronleventhal)
You need to log in before you can comment on or make changes to this bug.