Would like auto-complete URL to use saved bookmarks as well as from History

VERIFIED DUPLICATE of bug 166288

Status

Camino Graveyard
Location Bar & Autocomplete
--
enhancement
VERIFIED DUPLICATE of bug 166288
11 years ago
11 years ago

People

(Reporter: Steve Harrington, Unassigned)

Tracking

({helpwanted})

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.4) Gecko/20070509 Camino/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.4) Gecko/20070509 Camino/1.5

As my Mac is used in a shared environment, I delete the cache and history at the end of each session. I note that the auto-complete only seems to work on sites in your history. It would be really helpful if the auto-completion picks up on saved bookmarks too. As I delete the history every day, the auto-complete doesn't pick up anything as I start typing a URL, despite the site I want being in my bookmarks. Safari uses bookmarks in the auto-completion feature, as do most other browsers - is there any chance this could be added in a future release of Camino.

Reproducible: Always

Steps to Reproduce:
1. Save a bookmark
2. Delete History and/or Cache
3. Start typing URL of website, the auto-complete doesn't use the saved bookmark
Actual Results:  
Auto-complete doesn't work if you delete History. Would like it to also use saved Bookmarks as well.

Expected Results:  
I'd like auto-complete to use saved Bookmarks when you start typing a URL.

I appreciate this isn't a bug as such, but more of a refinement of an existing feature. If you take a look at Safari as an example, the auto-completion of URLs also uses saved Bookmarks in the suggested results as you start typing a URL in the location bar.

The auto-completion feature works fine with the History, but if you delete the History - as many people in shared environments do - then the auto-complete doesn't pick up any suggestions, even if those sites are in your saved Bookmarks.

If this could be added as a feature in a fture release of Camino, that would be great.
(Reporter)

Updated

11 years ago
Keywords: helpwanted
Please search before filing bugs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 166288

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.