"Check for updates" ignores new versions

RESOLVED INVALID

Status

Thunderbird
General
--
major
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Shad Sterling, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: (sorry, I upgraded while I was checking for previous reports)

Thunderbird 1.5 never tells the user that 2.0 is available, even when the user asks it to check for updates - it even says that no updates are available, which is highly misleading.

Reproducible: Didn't try

Steps to Reproduce:
1. run Help | Check for Updates
2. wait for it to check
3. see the wrong message that there aren't any


Expected Results:  
I expected it to automatically upgrade, as it has for every other update.
(Well, I assume it didn't ignore any others - if it did I'd have no way to know.)

I can see why it might be bad to change major versions automatically, but to say there are no updates available when the next major version is available is a lie.

Comment 1

11 years ago
The automatic upgrade from 1.5 to 2.0 isn't (yet) activated. You can expect it very soon. <http://developer.mozilla.org/devnews/index.php/2007/06/06/rollout-of-major-update-for-firefox-15-to-20/> speaks about the Firefox upgrade, the Thunderbird upgrade will follow after that one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

11 years ago
Oops, sorry.. I went to report another bug, and just to be sure I checked mozilla.org/thunderbird, which has a download link for 2.0.0.0, so I was confused.

Why isn't the download link on the product page changed at the same time as the automatic update?

Comment 3

11 years ago
Several extensions were not compatible with Firefox 2.0 or Thunderbird 2.0 at first, so Mozilla wanted to wait until it was absolutely safe to upgrade. Some people would click on anything, without reading the warnings :-)

In case of Firefox, we needed first several changes (delivered as part of firefox.1.5.0.12), before we could offer a 2.0 update, because the update-system would not have worked for various reasons. I guess Thunderbird was the same.
(Reporter)

Comment 4

11 years ago
That makes good sense.  I think I would've understood right away if the website had mentioned it.  Thanks for explaining.
(BTW I was able to upgrade without any trouble; I assume because I didn't have any problematic addons.)
You need to log in before you can comment on or make changes to this bug.