use X-Original-To header information when replying to email (multiple identities)

RESOLVED DUPLICATE of bug 377998

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 377998
11 years ago
10 years ago

People

(Reporter: Matp75, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Thunderbird version 2.0.0.0 (20070326)

When receiving a email for a email aliases, I'm expecting a reply to leave with my email aliases account properties when replying.
This works well when my email aliases is present in the To field.
This doesn't work when I'm receiving the mail as a bcc.(mailing list or just somebody using the bcc feature)
As a workaround I have to reselect my correct identity when replying.
As my email server added a (optional) header X-Original-To: with the real final recipient, I would like thunderbird to use this information for the reply :

If Field to contains one of my email aliases -> use this information
elsif X-Original-To: exist and contains one of my email aliases use this
else use my primary email for this account


Reproducible: Always

Steps to Reproduce:
1. create a account user@example.com
2. add an email aliases (another identity) useralias@example.com
3. from another email client(test@anotherdomain.com) , send a mail to test@anotherdomain.com with useralias@example.com in bcc.
4: mail is received in your mail box and your mail server adds a X-Original-To: useralias@example.com) (seems like postfix does the job well but not exchange)
5 : reply to it
6 : look at the email used for reply 
Actual Results:  
Thunderbird uses user@example.com setting in the from 

Expected Results:  
Thunderbird uses useralias@example.com setting in the from

Comment 1

11 years ago
I think this is really bug 327713.
(Reporter)

Comment 2

11 years ago
No, I don't think so.
I don't use any global inbox functionality and don't see any X-Account-Key in my mails (I search for this in my inbox file without finding any)

The reply to functionality for multiple identities works well when the To: field contains a secondary identity.

this bug is about using a specific header to allow thunderbird to guess the correct identity to use when it's not guessable from the To: field.

see http://www.postfix.org/local.8.html for information about X-Original-To header  

the local(8) daemon  prepends  an  X-Original-To: header with the recipient address as given to Postfix

Comment 3

11 years ago
I believe this is a version of the problem I also experience with Thunderbird. I have two separate e-mail accounts: 123@example.com and abc@another.com. Both are directed through Account 1: 123@example.com and so come into my e-mail from the server for that account. They are then sorted into folders under their respective identities. Regardless of which identity I am working in, the default/autocomplete From: address is always the one for the account through which the e-mail has been routed, not the identity I am currently working in. I can choose the correct From: identity but this is an extra step and as such is easy to forget.   

Reproducible: Always

Steps to Reproduce:
1. create two identities - 123@example.com and abc@another.com
2. have the mail from 123@example.com forwarded to abc@another.com
3. set up a message filter to sort incoming messages with "frustrated" in the subject line to a folder under the 123@example.com identity
4. from an unrelated third e-mail account, send an e-mail to 123@example.com with "frustrated" in the subject line  
5. when it arrives, it should get sorted into the 123@example.com folder as per your filter
6. highlight the "frustrated" e-mail 
7. reply to it
8. note the From: and Reply-to: addresses are abc@another.com
Actual Results:  
Thunderbird uses abc@another.com setting in the From: not 123@example.com, even though I am operating in the 123@example.com identity.

This problem does not arise when simply composing a message. In that case the From: address correctly reflects the identity I am currently working in. 

It strike me that this may bear a relationship to 273526, 362470, 29908, 377998, and the always present 327713. 

Note that Mozilla did not have this problem. It always defaulted to the identity you were working in regardless of what address the e-mail had been sent to or what server it had been routed though. 

Comment 4

11 years ago
Yeah, i suppose you are on imap then (imap don't have x-account-key header). Though then there is bug 230247.

Ursule: I think that your case is bug 377998. Also, please write "bug" before bug numbers so they get autolinked. 
(like bug 273526, bug 362470, bug 29908, bug 377998 and bug 327713. 

Comment 5

11 years ago
Thanks for the pointer about adding the word "bug".

I am not on imap and having looked at bug 230247, that is not it easier. Mine does not involve a mailing list. 

I have come to the conclusion that is is soemthing in the way the code is written or the configurations are set on default but I am reluctant to get in there and muck about in case it causes new problems. I'm not at all a techie, nor do I have time to spend experimenting, given my lack of knowledge. I'm hoping at some point a techie will be able to fix this.  

Comment 6

11 years ago
You may be right about bug 377998 but to be honest I cannot follow the information to determine if it is. What I do know is that it dis not work correctly in any past version of Thunderbird I had although it did work correctly in Mozilla. 

Comment 7

10 years ago
does the virtual-ID plugin help (https://addons.mozilla.org/en-US/thunderbird/addon/594)?  

If so, I think this bug should be closed as WONTFIX and the functionality should be added via the plugin.  Mozilla products are torn in too many directions and plugins are there to help with customization.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Whiteboard: closeme 2008-08-30
In lieu of more information, it seems that bug 377998 is the same effect as this bug. That was fixed on trunk builds (i.e., TB 3.0).

In any case, I think the summary of this bug is off.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: closeme 2008-08-30
Duplicate of bug: 377998
You need to log in before you can comment on or make changes to this bug.