Closed Bug 383640 Opened 15 years ago Closed 15 years ago

It should be permitted to make a quick search without entering any words

Categories

(Bugzilla :: Query/Bug List, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 385910

People

(Reporter: rd, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Bugzilla 3.0

Starting from Bugzilla 3.0 possibility to do a quick search without adding any words was removed. This limitation is too strong, because it is a common task to find 'Any open bugs' for some product without adding any key words.

Currently alert message "The Words field cannot be empty" appeared and user have to add '%' word to search string to make a simplest task.

Reproducible: Always

Steps to Reproduce:
1. Choose "Search" at the header line
2. Choose "Find a specific bug" tab
3. Choose any product, any status and leave "Words" field empty
4. Press "Search" button
Actual Results:  
Alert message "The Words field cannot be empty" appeared

Expected Results:  
Show all results with requested criteria as works with Bugzilla 2.x 

There was a reason to restrict "empty search" for some huge installation like mozilla.org, but in such case it should be possible to disable such limitation by Bugzilla configuration.
Version: unspecified → 3.0
Marking this bug as a dupe of bug 385910 despite this bug is older. The other bug already has a patch, that's why.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 385910
You need to log in before you can comment on or make changes to this bug.