Firefox sucking resources dry from hardware.

VERIFIED INCOMPLETE

Status

()

Firefox
General
--
major
VERIFIED INCOMPLETE
11 years ago
7 years ago

People

(Reporter: Justin Weaver, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30)
Build Identifier: 2.0.0.4

When using the program Mozilla Firefox, it basically sucks my processor and RAM dry. I've also come to realize that I'm not the only one with the problem. I honestly love firefox which is why I'm wiriting this. I have a a 2.20 GHz processor and 512MB of RAM, so I know it's not because I'm low on those. The only other program I run with it is MSN Windows Live Messenger.

Reproducible: Always

Steps to Reproduce:
1.Restart Firefox
2.
3.
Actual Results:  
Starts over and begins with not so many resources being used, to have my RAM and processor maxed.

Comment 1

11 years ago
Eh, your user-agent string indicates you're running IE7 and not Firefox. I suspect some firefox extension or special firefox build is at play here, maybe you could provide some more information?
(Reporter)

Comment 2

11 years ago
Yes. I started using IE7 again because firefox wants to be troublesome. But no, the only thing I have special on firefox is a skin, and that was just added recently, but firefox has ALWAYS maxed my stuff out. I dont use add-ons for firefox because of the issue at hand.
try some of the following steps to narrow down the source of your mentioned problems :

http://kb.mozillazine.org/Safe_mode
http://kb.mozillazine.org/Firefox_CPU_usage
http://kb.mozillazine.org/Firefox_hangs
(Reporter)

Comment 4

11 years ago
(In reply to comment #3)
> try some of the following steps to narrow down the source of your mentioned
> problems :
> 
> http://kb.mozillazine.org/Safe_mode
> http://kb.mozillazine.org/Firefox_CPU_usage
> http://kb.mozillazine.org/Firefox_hangs
> 

No one is listening. I DO NOT have add-ons. None. Nada.

Comment 5

10 years ago
This bug lacks sufficient information to do anything with it, so => incomplete.
Also does not meet criteria for critical.  please read https://bugzilla.mozilla.org/page.cgi?id=fields.html#bug_severity

If you have a reproducible testcase or URL that causes problems, with steps to reproduce, then please post the information and reopen the bug. But frankly I don't see a firefox problem, you simply won't get good performance with XP on 512MB memory - in fact you are _guaranteed_ to have poor performance.  IMO the best you can do is work on optimizing your XP environment and going through the list at http://kb.mozillazine.org/Reducing_memory_usage_(Firefox)

Also, FF3 will use less memory in many situations, so give it a a try when it becomes available.
Severity: critical → major
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Keywords: perf
Resolution: --- → INCOMPLETE

Updated

7 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.