Deleting an email selects the next email inappropriately

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
--
major
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: Roman, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-03-05, URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: version 2.0.0.0 (20070326)

My IMAP server is a bit slow - deleting an email takes around 1 second. Upon my pressing of "Del", Thunderbird seemingly does nothing - I then proceed to read some other email. After a second, the email gets deleted from the list and the next email gets selected automatically.

Upon pressing "Del" the email should disappear from the list immediately and the next email can then be selected in a much more appropriate way. If one insists on the email staying in the list for the duration of the delete operation then my manual selection of another email should not be overridden.

(I strongly prefer a solution which drops the email from the list immediately - otherwise Thunderbird feels sluggish.)

Reproducible: Always

Steps to Reproduce:
1. Connect to a somewhat slow IMAP server
2. Press "Del" and immediately select a different email using the arrow keys
3. Wait until the email you deleted is gone.
Actual Results:  
The email disappears from the list after a long delay. The next email gets selected, despite the fact that I've already navigated away from there.

Expected Results:  
The deleted email should disappear immediately. Alternatively, Thunderbird should not override my selection if I navigated away.

Comment 1

9 years ago
I'm frustrated by this too. However, rather than simply add a "Me Too" comment I would note that this is probably more frustrating if like me you prefer to order your emails in descending order to date. So, when you usually would want to look at the message immediately *up* from the one you just deleted, but it currently automatically forces you to go the next one down.

Comment 2

9 years ago
This bug has been reported on Ubuntu Launchpad as:

https://bugs.edge.launchpad.net/thunderbird/+bug/311827

Comment 3

8 years ago
do you see this also with version 3?
Component: Mail Window Front End → Folder and Message Lists
QA Contact: front-end → folders-message-lists
Whiteboard: closeme 2010-03-05
Version: unspecified → 2.0
(Reporter)

Comment 4

8 years ago
It seems that deleting in TB3 makes the email disappear from the list immediately. So no, I cannot reproduce this in v3.

For the record, I also stumbled across these related bugs: bug 471519, bug 274628, bug 395151.

Please resolve as I don't know which status to choose.
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
You need to log in before you can comment on or make changes to this bug.