selecting prefs/fonts with up/down keys only selects every other row

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
normal
VERIFIED WORKSFORME
18 years ago
9 years ago

People

(Reporter: R.K.Aa., Assigned: Stuart Parmenter)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
M16 Linux 2000-050513
This worked OK only a couple of builds ago.

-Open edit/preferences and select appearance/fonts
-open any dropdownbox with fonts
-move cursor over it so one line gets selected
-then use down-arrow on keyboard to maneuvre down

Result: Only every second font listed gets selected - the next is skipped.

Comment 1

18 years ago
Can't repro on 20000050608 win98.  Is this reproducible on mac, or is this pp 
linux?
Keywords: regression
hm, i couldn't repro this on mac, winNT or linux, using opt comm bits from
today, 2000.05.08/11. do reopen if this occurs again with a recent build...
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

18 years ago
2000-050820
same thing.
When placing cursor over a font in a dropdownbox the font gets a blue baclground
indicating selected. without clicking, use arrow up/down to maneuvre, and only
every second row gets the blue background.
There seems to be more of a problem as well:
When i earlyer used this "trick" - keying down - to access fonts that are now
out of view because the box drops "below screen" - i could "count my way" to the
font i wanted. when keying out of view, selections took place. When i now key
down out of view, and the key back up again - the selection never "comes back".
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
installed today's mozilla bits on linux [2000.05.09.08], and i wasn't able to
repro this problem... jrgm, have you seen this before in other menulists? ben,
does this sound familiar at all to you? (feel free to reassign to the
appropriate owner.)

here's what i did --R.K.Aa, let me know if what i'm doing here differs from your
steps:

1. open Prefs dialog, select Fonts category.
2. i go to one of the font menulists, eg, Serif. my current setting there is
"garamond" and i have a total of 25 fonts in the Serif menulist.
3. dropdown the menulist (click once w/mouse). "garamond" is now highlighted
(blue backgrnd, white text).
4. using the up arrow key, scroll upwards (also, use down arrow key to scroll
downwards).

result: i'm able to scroll up/down one item at a time in the menulist.

i wonder if it's a window management issue? i'm using Enlightenment (over
gnome). what are you using?
Assignee: matt → ben
Status: REOPENED → NEW
(Reporter)

Comment 5

18 years ago
You're right: Tested E0.16.3 and the behaviour was as you describe.

I've used Gnome/Sawmill 0.26 for months and it hasn't "skipped" a line till i
reported this bug. I check font preferences on just about every build: my own
little smoketest, since there seems to be daily surprices in that section
(scrollbars coming, going etc.) Whatever has changed has changed in Mozilla, not
Sawmill.

Comment 6

18 years ago
Nope. Can't reproduce. I also tried with a different window manager (twm)
but could not see it there either. 
(Reporter)

Comment 7

18 years ago
hmm well the error here affects all dropdown boxes it seems. While keying
up/down in forms without dropdowns work OK.
At http://www.cnn.com/WEATHER there's a dropdownbox where you can select cities:
There the behaviour is particularly odd:
When i mouse down i see the headline in the box actually briefly displaying the
selection that gets skipped - but shortly after the actually marked selection
(that gets "blue") will "settle" on the next city, and then that city refresh in
the box instead. After a few more key down occurances, another error happens -
the city that is marked selected suddenly gets selected like if i had clicked
enter, and browser goes on to a new page displaying that URL.

Set as wfm if you want, it's no big issue, but i have a hunch this isn't the
last you've heard from this bug. I won't persuit it further though, but i do
find it annoying since it blocks the last GUI workaround to set preferred font
settings. I now have to edit prefs.js manually - what a chore ;)
h'm, pavlov uses sawmill...and after seeing R.K.Aa's last comment, this sounds
like a more general toolkit issue. over to pav (for the nonce, at least :-)!
Assignee: ben → pavlov
Component: Preferences → XP Toolkit/Widgets
QA Contact: sairuh → jrgm
ugh, these should go back to me...
QA Contact: jrgm → sairuh
(Assignee)

Comment 10

18 years ago
in a build from today, it works fine
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
feel free to verify these (or reopen, if still a problem) if i don't get around
to it beforehand. if you do so, pls do remove the verifyme keyword after
verifying a given bug. thx!
Keywords: verifyme
(Reporter)

Comment 12

18 years ago
i still see this in build 2000-080409 M18, but perhaps a fix was checked in
later, or on the branch only?

Comment 13

18 years ago
vrfy wfm on Linux 2000-08-13-09
Status: RESOLVED → VERIFIED

Updated

9 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.