Closed Bug 383763 Opened 14 years ago Closed 14 years ago

Seemingly random crashes in cycle collector code [@ nsCycleCollector::MarkRoots]

Categories

(Core :: XPCOM, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Gavin, Assigned: graydon)

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

There's no clear steps to reproduce, the browser will just crash in as I'm browsing, or switching away from the active window. I'll attach an example of a stack that I've seen a couple of times.
Attached file stack
These crashes started happening to me some time in the past week or so. I don't really have further details, I'll try running a debug build and see if I can debug further.
I'm seeing this on Windows nightly builds, started in the past 3 days or so.  It's frequent enough that using trunk as my daily browser is difficult.  I generally have 3+ tabs open, with gmail, tinderbox, and a few other things open.
This is probably my checkin of the patch for bug 368869. Guess nothing has changed under Igor's new work. I have never been able to reproduce this, but it seems to simply not work. Backing out.
Status: NEW → ASSIGNED
Assignee: nobody → graydon
Status: ASSIGNED → NEW
I pulled and built right after this backout, and I've been crash-free since.  I'm still a bit worried since this crash wasn't triggering Breakpad for me on Win32.
Can we close this if nobody's seeing it anymore? I'm pretty sure I caused it.
I've seen no crashes since you backed out the patch.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsCycleCollector::MarkRoots]
You need to log in before you can comment on or make changes to this bug.