If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

large white space on page

VERIFIED DUPLICATE of bug 37618

Status

()

Core
HTML: Parser
P3
normal
VERIFIED DUPLICATE of bug 37618
18 years ago
17 years ago

People

(Reporter: Warren Harris, Assigned: harishd)

Tracking

({testcase, top100})

Trunk
x86
Windows NT
testcase, top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
This page renders with a large white space above the "Photo Equipment and 
Consumer Electronics" image heading on the left hand side.

Comment 1

18 years ago
Created attachment 8396 [details]
test case

Comment 2

18 years ago
The large white space is caused by the contents of a dropdown listbox being 
dumped into the content.

Apparently the </font> tag inside the <option> is being treated as the end tag 
for another <font> tag above the select, causing the browser to assume that 
there should have been a </select> and adding one automatically.  Removing the 
<font> tag inside the option (supposedly the start tag for the </font>) doesn't 
affect IE _or_ mozilla, so I guess IE always treats <select> as having higher 
precedence or something, whereas mozilla ignores the opening <font> tag AND 
treats them as having the same precedence.  (I think I'll stop speculating now 
and just send this to the parser people.)
Component: Layout → Parser
Keywords: testcase, top100

Comment 3

18 years ago
sounds like jesse has done a great analysis.  harish?
Assignee: troy → harishd
(Assignee)

Comment 4

18 years ago

*** This bug has been marked as a duplicate of 37618 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.