The text caret is hidden when it is in front of a fixed div

RESOLVED INVALID

Status

()

Core
Layout: View Rendering
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Vladimir Panteleev, Assigned: roc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Opera/9.21 (Windows NT 5.1; U; en)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

See URL ( http://thecybershadow.net/dump/ad62af9a85ab22d0e21220fe00a59e4b/test.html ) for more information. The text caret's visibility seems to be masked by the fixed div behind the textarea. When the caret is above the ----- line, it's hidden; when it's below the line, it's visible, like it should be; when it's on the line, only the bottom half is visible.

Tested on Windows and Linux.

Reproducible: Always

Steps to Reproduce:
N/A (see link and source)
Actual Results:  
see above

Expected Results:  
The cursor should be always visible
This is fixed on trunk. Please test trunk builds since they contain 2 years worth of bug fixes at this point...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.