Session Restore Broken

VERIFIED INCOMPLETE

Status

()

VERIFIED INCOMPLETE
12 years ago
9 years ago

People

(Reporter: tonemgub, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; OpenBSD i386; en-US; rv:1.8.1.3) Gecko/20070430 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (X11; U; OpenBSD i386; en-US; rv:1.8.1.3) Gecko/20070430 Firefox/2.0.0.3

The session restore feature is broken. This problem seems to be tied to the fact that the "Home Page:" is not set by default.

If a user selects "Show my windows and tabs from last time" on a fresh install without setting the home page, then the session restore will not work.

If you set a "Home Page:" then everything works as expected and the previous session is restored on startup.

Reproducible: Always

Steps to Reproduce:
On a fresh installation of firefox 2.0 
1. go to menu Edit->Preferences
2. select "Main" section
3. on the "When Firefox starts:" select "show my windows and tabs from last time"
4. load a few pages in tabs
5. File->Quit
6. restart firefox

NOTE: On a default install, "Home Page" setting in preferences is blank/empty.
Actual Results:  
Firefox opens with a blank page

Expected Results:  
Firefox should restore the previous session (tabs and windows)

The work-around is simply to set the "Home Page" (on the "Main" section of preferences) to something rather than leaving it blank.

Since you're restoring sessions on startup, there's no point in setting a "Home Page" at all, since you never actually load it (outside of using the "Home" button or similar).

Comment 1

12 years ago
I remember already having seen such a bug once, but at least on Windows this works since Firefox 2.0.0.0.

Can you please go to about:config, make sure that javascript.options.showInConsole is set to true and then check the Error Console for errors right after reproducing this bug?

Also: Are you able to reproduce the issue on a clean profile or in safe-mode?
Component: Preferences → Session Restore
QA Contact: preferences → session.restore

Comment 2

12 years ago
on version 2.0.0.4 / feisty i had something that maybe linked to this bug :
- i used to have a systematic session restore message at stratup eventhough i closed firefox normally
- reading this bug i changed my default blank page to something and now my bug has disappeared

Comment 3

12 years ago
i have setup the starting page to a blank page again and my bug has not come back - i.e. the systematic session restore is not there anymore ...



Comment 4

12 years ago
Reporter (should you really happen to check your Mailinator account again): please answer the questions from comment #1, otherwise this bug will be closed as INCOMPLETE.
Whiteboard: CLOSEME 07/14

Comment 5

12 years ago
(In reply to comment #1)
> I remember already having seen such a bug once
That's bug 375829.

Comment 6

12 years ago
Reporter: Please reopen this bug in case you're able to provide further information (see comment #1).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INCOMPLETE
Whiteboard: CLOSEME 07/14
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.