Closed Bug 383812 Opened 15 years ago Closed 15 years ago

Download manager does not handle ftp downloads well/usually

Categories

(Toolkit :: Downloads API, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 355222
mozilla1.9alpha7

People

(Reporter: robarnold, Unassigned)

References

()

Details

(Keywords: regression)

Click the link 79d531ww.exe, then hit 'I agree' and make sure ftp is selected, not http. The dialog to save the file will popup (save/cancel), pick save. The file does not appear in download manager nor does it appear to be downloaded. Some other ftp sites do appear to work, but lenovo's appears to fail fairly reliably.
Can you possibly find a regression range?  (I suggest just before Bug 380250 landed as a starting point)
Duplicate of this bug: 386990
fwiw, I am not sure this is limited to ftp:// downloads.

From bug #386990, both the http:// and the ftp:// options have issues.
As rob and ria have pointed out, this looks like a regression from bug #353560
Flags: blocking-firefox3?
has anybody backed out that patch and tried it yet?
Flags: blocking-firefox3? → blocking-firefox3+
Target Milestone: --- → Firefox 3 M7
This is basically the same issue as bug 355222, I think. The branch patch that was landed there would probably fix this bug.
Hardware: PC → All
Indeed, the patch in bug 355222 fixes this for me, by not closing the download-triggering window and using it as the dialog's parent if it's opener is closed. I'd say this is a straightforward dupe of bug 355222. The only thing that the  patch for bug 353560 did was make the problem more general - we now don't call saveToDisk() at all, because the timeout is on a closed window, whereas we used to only fail if saveToDisk() called promptForSaveToFile() (i.e. if "ask me where to save this file" was true and we tried to init a filepicker with a null parent).
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355222
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.