If training.dat is missing "Run Junk Mail Controls on Folder" marks all messages as junk

RESOLVED DUPLICATE of bug 250470

Status

--
major
RESOLVED DUPLICATE of bug 250470
12 years ago
2 years ago

People

(Reporter: cbook, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Tested with Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.4) Gecko/20070604 Thunderbird/2.0.0.4 ID:2007060411 on Windows and Linux

When you click on "Run Junk Mail control on Folder" all messages are marked as junk.

STR:

1. Create a new profile
2. Setup a POP3 / IMAP Account (i used yahoo mail and my mozilla.com Account)
3. Download some messages
4. Click on Run Junk mail control on folder
5. All Messages are marked as junk

Could be confusing to new users
(Reporter)

Updated

12 years ago
Version: Trunk → 2.0
Severity: normal → major
This can also be seen with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a6pre) Gecko/20070614 Thunderbird/3.0a1pre ID:0000000000 [cairo]

I did the same steps like Carsten and all messages within the newly created POP3 account were marked as Junk. 
Component: General → MailNews: Filters
Product: Thunderbird → Core
QA Contact: general → filters
Version: 2.0 → Trunk
I did a further test after I had an idea why that could happen. And yes, if the training.dat is missing and you run the junk mail controls all your messages are marked as Junk. But the junk log doesn't has any entry and the messages are also not moved to the specified junk folder. So the messages are not really junk?
Summary: Run Junk Mail control on Folder result in all Mail marked as junk → If training.dat is missing "Run Junk Mail Controls on Folder" marks all messages as junk

Comment 3

11 years ago
see andrew's bug 355197.

startup should warn if it detects training.dat is missing and JMC is turned on.

Comment 4

11 years ago
In nsBayesianFilter.cpp there are the comments:

    // the algorithm in "A Plan For Spam" assumes that you have a large good
    // corpus and a large junk corpus.
    // that won't be the case with users who first use the junk mail feature
    // so, we do certain things to encourage them to train.
    //
    // if there are no good tokens, assume the message is junk
    // this will "encourage" the user to train
    // and if there are no bad tokens, assume the message is not junk
    // this will also "encourage" the user to train

So it would seem this behaviour is by design.
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Updated

2 years ago
Duplicate of this bug: 516604

Updated

2 years ago
Duplicate of this bug: 1224716

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250470
You need to log in before you can comment on or make changes to this bug.