Click to activate Thunderbird windows

RESOLVED DUPLICATE of bug 392188

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 392188
11 years ago
10 years ago

People

(Reporter: Sina, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: 20070326

If you have multiple Thunderbird windows open (e.g. search, compose mail, and inbox), it is necessary to click once to activate each window before using any of the Windows features. This "click-to-activate" between Thunderbird windows should be disabled as it can be very frustrating. 

If anyone knows a way of preventing click-to-activate in general for all Mac OS X windows, I would appreciate an e-mail as I'm having a hard time working out how to change this. 

Reproducible: Always

Steps to Reproduce:
1.Compose new message
2.Click between new message and main Thunderbird window
Actual Results:  
You have to click once to activate the window before you have access to any of the window content or buttons

Expected Results:  
Allowed immediate access to window content. Since all the windows are within the same application, this makes sense.

Comment 1

11 years ago
This bug is very annoying. It's one of the reasons I'm considering switching to Apple Mail.

Comment 2

11 years ago
9/20/07 - I was about to put this bug in myself when I found this slight variant. I agree it is annoying, but not enough to switch to Apple Mail. Basically, I think the report should read:

On MacIntosh, the user has to click on the title bar to activate the Thunderbird window you have switched to. But normal MacIntosh apps it is possible to click anywhere within any window to activate it. That's the problem.

Comment 3

11 years ago
Responding to comment #2, this bug is not about needing to click specifically the title bar in order to activate a Thunderbird window (under Mac OS X). You can click any area of the Thunderbird window.

*The original report is 100% consistent with my experience.*

Comment 4

11 years ago
Aha! Well, that made me do further confirmation. Here is my experience: I have two thunderbird normal mail windows open (on two different monitors if that makes a difference) in OSX. Both windows are the standard three pane view. It seems you are correct, the FIRST time, it seems I can click on any portion of the second window the FIRST TIME I click to it. But from that point on, when I alternate between windows, I MUST click the title bar of any window to activate the window from this point on. This is what is very non Mac-like and frustrating. I hope this clarifies the bug. 
I'm not sure if Thunderbird is working as intended, as Firefox also has to be "clicked" before activated.

Bryan, thoughts?

Comment 7

10 years ago
(In reply to comment #5)
> I'm not sure if Thunderbird is working as intended, as Firefox also has to be
> "clicked" before activated.
> 
> Bryan, thoughts?


This is Bob Katz, not Bryan :-). Anyway, Firefox does NOT have this behavior in OS 10.4 at least. If you click anywhere on a Firefox window, it activates, you do NOT have to click on its titlebar. It would be wonderful if a developer worked on this bug in Thunderbird.
Bob: what you are doing, taking someone else's bug report about something only vaguely related to what you are seeing and trying to turn it into being about your problem, is called bug hijacking, and it's frowned upon. Even if everyone sees what you see, and nobody sees what the bug was about originally, it still makes for a confusing bug report. In cases like this, where nobody sees what you see, and everybody sees what was originally reported, it makes it both confusing and frustrating.

Even though this was reported first, bug 392188 (which is about what this bug was about, and not about your issue, Bob) made it into the proper Core component first and got useful information in it first, so I'm duping forward to there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392188
You need to log in before you can comment on or make changes to this bug.