Cursor hidden by Flash stays hidden on mouse exit of content pane

RESOLVED WORKSFORME

Status

Camino Graveyard
General
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: peeja, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.4) Gecko/20070509 Camino/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.4) Gecko/20070509 Camino/1.5

If a Flash object hides the cursor (eg, to display it's own cursor), moving the cursor out of the Flash area does not un-hide the cursor.  Moving the cursor out of the content pane altogether also does not un-hide the cursor.  The following seem to be the only ways to make the cursor reappear:

1. Clicking.
2. Mousing over another Flash area or the location bar (but not the search bar, or any other control tht I've found).
3. Certain keystrokes, such as Cmd-Esc, Cmd-`, or Cmd-B, but not, for example Cmd-L or Cmd-Shift-F.

Reproducible: Always

Steps to Reproduce:
1. Go to a page containing a Flash object which hides the cursor, such as the attached URL.
2. Mouse over the Flash object and let the cursor disappear.
3. Move the cursor out of the Flash area.
Actual Results:  
Cursor remains hidden until one of the above occurs.

Expected Results:  
Cursor should reappear on exiting Flash area.

Comment 1

11 years ago
Is this different than bug 325558?
(Reporter)

Comment 2

11 years ago
Well, sort of.  I hadn't found that one, but that bug says it only happens when the Flash is against the side of the content pane.  I see it no matter where the Flash is.  Probably refers to the same problem, though.  Dup?
(Reporter)

Comment 4

11 years ago
(In reply to comment #3)
> There's also bug 332597.

Looking at the source of the page above, the Flash is contained directly by a <td>, not a <div>, and there's room to either side of the <td> in which the cursor remains invisible, so I'm guessing it's unrelated.  Also, if the problem is that the Flash object isn't receiving a mouseOut, that implies that the Flash has control over the visibility of the cursor no matter where the cursor is.  If that's true, heaven help us.  :)
Is this still true on the trunk, or on the trunk with the beta Quartz Flash plugin?
And/or in Minefield, with the same "also or" as above?
(Reporter)

Comment 7

11 years ago
Looks fine on straight trunk.  Closing WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Duplicate of this bug: 400642
You need to log in before you can comment on or make changes to this bug.