Problems viewing HTML attachments if one of them is Netscape home page

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
19 years ago
9 years ago

People

(Reporter: momoi, Unassigned)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
** observed with 5/5/2000 Win32 build **

Hopefully this has been noticed before,
Here's how to reproduce this problem:

1. Use 4.73 to compose HTML message.
2. Write a few lines in the body. 
3. Open an attachment pane, and drag and drop a (navigation) link from a web page 
   opened on a Browser window. Attach 1) http://www.yahoo.com and 2) http://home.netscape.com
4. Send this message to your mail account and view it with Mozilla.

Results:

The Yahoo attachment seems to load first, and then Netscape page attachment loads. In the message
view window, only part of the Netscape page is loaded. The Yahoo attachment is not displayed
and is not in the view window even when you scroll up and down. So what you see is a partially
loaded Netscape page.

Expected Results:

We should be able to display both attachments in their entirety in sequence, i.e. Yahoo page and then NS
page. 

Additional problem:

Sometimes, trying to display this message will lead to a crash. In my case, it happens
sometimes when I first open a mail box and click on this message. Als seems to occur
when you copy this message to another folder and then open that folder and try to
dispaly that message. 

A similar problem (though not completely the same has been reported in Bug 32737.

Talkback dumps available. Use momoi@netscape.com as the E-mail address. When the search
results are dispalyed, incidents 10008413, 10008527, 10008931, and 10009097 recorded on 5/6
are all of the same crash.

Updated

19 years ago
Severity: normal → major
QA Contact: lchiang → pmock
(Reporter)

Comment 1

19 years ago
Nominating for nsbeta2 since this is basic functionality impairment.
Keywords: nsbeta2
(Reporter)

Comment 2

19 years ago
It turns out that we have this problem or the crashing 
problem only when the current Netscape Home Page is atatched.
So this might be something to do with a particular layout
problem with the Netscape Page.

I'll attach the Netscape Home page to this bug.
If I send this page attaching it locally to a message with
4.73, then I consitently crash with 5/8/2000 Win32 build when
trying to view it. If I attach a page like Yahoo in front of it,
then I get to display only part of the Netscape Page but nothing
of the Yahoo page.

I'll file a  crashing bug as a separate bug though
that and the display problem seems to be related.
(Reporter)

Comment 4

19 years ago
CC'ing rickg.

Comment 5

19 years ago
Putting on [nsbeta2+] radar for beta2 fix.
Whiteboard: [nsbeta2+]

Comment 6

19 years ago
this is a dup of another bug..lemme try to dig itup.

Comment 7

19 years ago
Target M17.
Target Milestone: --- → M17

Comment 8

19 years ago
This should be fixed now.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 9

19 years ago
Re-openning bug.
This problem still occurs in today commercial seamonkey win32 builds 2000-052408 
and MacOS 2000-052408-m16.

Following the original problem scenario, the Netscape home pages is the only 
visible page even though you attached the yahoo home page.  It does not matter 
what order I attach these web page.  

On Linux commercial seamonkey build 2000-052408-m16, it fails to load the page 
in the messenger pane.  The application freezes and the terminal window always 
says "STYLE CHANGE REFLOW. Blowing away all box caches".  
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 10

19 years ago
I tried this today on win32 with a tip of the trunk build (release and debug) - 
both web pages were displayed. Someone probably fixed this in the last month. 
Please reopen if it's still broken for you.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME

Comment 11

19 years ago
Re-openning bug.
This problem still occurs in today commercial seamonkey builds:
Linux (2000-07-26-08 M17)
Win32 (2000-07-26-09 M17)
Same result as described by Peter earlier.
"Following the original problem scenario, the Netscape home pages is the only 
visible page even though you attached the yahoo home page.  It does not matter 
what order I attach these web page."  

Mac build not ready yet.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 12

19 years ago
I wouldn't hold the beta for this re-opened bug. Moving to beta3. 
Keywords: correctness, nsbeta3
Whiteboard: [nsbeta2+]

Updated

19 years ago
Keywords: mail2

Comment 13

19 years ago
Putting on [nsbeta2-] radar. Not critical to beta2. 
Whiteboard: [nsbeta2-]

Comment 14

19 years ago
possible item for b2 release notes
Keywords: relnote2

Comment 15

19 years ago
b3 need info.
Does this happen with any other pages/attachments? Perhaps try a few other 
combinations. Perhaps something with layout of Yahoo's page?
Whiteboard: [nsbeta2-] → [b3 need info][nsbeta2-]

Comment 16

19 years ago
fyi
 This problem appears to occur only with the combination of attaching the 
netscape home page with another web page.  I can attach other combination of web 
pages besides the  netscape home page and have it load successfully on all 
platforms.

For example, from win32 communicator 4.74 I sent the following combination of 
message with these attachments ...
 a) Netscape & Intel home page-> fails to render Intel page
 b) Intel & Netscape home page-> fails to render Intel page
 c) Intel & Mozilla home page -> successfully loads both home pages
 d) Mozilla & Intel home page -> successfully loads both home pages
 e) 2 gif file attachment -> successfully loads both home pages
 f) 1 png and 1 gif file attachment -> successfully loads both home pages
 g) Adobe & Microsoft home page -> successfully loads both home pages
 h) Yahoo & Microsoft home page -> successfully loads both home pages

My tests were performed using the following build:
 win32 commercial seamonkey build 2000-080909-m18
 linux commercial seamonkey build 2000-080808-m18
 macos commercial seamonkey build 2000-080908-m18

In short, it looks like there something that seamonkey doesn't like in the 
netscape home page.  If I let the application alone while trying to display the 
netscape & 2nd web page, it will finally display the error, "Alert! The 
operation timed out when attempting to contact home.netscape.com"

* Clearing white board status of [Need beta3 info] [beta3-] for re-evaluation.
Whiteboard: [b3 need info][nsbeta2-]

Comment 17

19 years ago
thanks for the detective work, Peter.  Modifying summary.
Summary: Cannot view more than 1 HTML attachments to a message → Problems viewing HTML attachments if one of them is Netscape home page

Comment 18

19 years ago
selmer will try to find a new owner for this per mail triage.
+ per mail triage.

peter: what happens if you take the source of the email for the attachments and 
copy and paste to a .html page and view in the browser?
Whiteboard: [nsbeta3+]
Target Milestone: M17 → M18
(Reporter)

Comment 19

19 years ago
I have a bit of time to look at this now that PR2-J shipped.
As I reported on 5/9, this problem happens only if one of the pages
attached is the current Netscape Home page.

Here's what seems to be happening.

1. Current Netscape Home page has JS scripts which sniff
   user-agent and load a slightly different page
   when you are Mozilla/NS6 (as opposed to Comm 4.7x).
2. You can either attach a live NS home page or one that
   is downloaded to your hard disk, the result will be 
   the same.
3. In other words, the page we are sending and attching as 
   NS home page and viewing with Comm 4.7x is not the
   same as the one which will viewed by Mozilla mail.
   Somehow a different page needs to be loaded for Mozilla/NS 6
   honoring the JS functions on the page. And we seem to do
   that but then nothing else gets downloaded after that
   from an IMAP server.

4. I turned off both Browser and Mail JS functions but this did not
   change the result. Still the same problem.

5. Then, I deleted 3 JS subsections which sniff the 
   user-agent and switch the content from the NS home page
   saved locally. Attched it along with a live Yahoo URL
   and send it using Comm 4.7x.  After this both
   the NS Home page (Looking like the Comm 4.7x home
   page) and a Yahoo page loaded correctly on Mozilla/NS6.

6. What I find curious is that with Mozilla/NS6, we don't even
   download the 2nd attachment (i.e. Yahoo page in this case) 
   from an IMAP server when the JS scripts of this type
   are present. I copied an imap msg of this type using
   Mozilla into a local mail foler and the 2nd attachment was not copied
   at all.

So, there seems to be some weakness on our part in dealing
with the IMAP server when this type of content is to 
be downloaded. While this may be limited to NS home
page now, there is no guarantee that that will be the case.

What is strange is that this problem occurs even when the 
JS functions are turned off. Also that the Mozilla/NS6
targeted page is showing instead. How is that possible
when we turn off the JS function via the prefs?

Comment 20

19 years ago
Putting on [nsbeta2-] since already [nsbeta3+]
Whiteboard: [nsbeta3+] → [nsbeta3+][nsbeta2-]

Comment 21

19 years ago
P2 per mail triage
Priority: P3 → P2

Comment 22

19 years ago
second pass: - per mail triage unfortunately.
Whiteboard: [nsbeta3+][nsbeta2-] → [nsbeta3-][cut 8/31][nsbeta2-]

Comment 23

19 years ago
sorry for the extra email. Removing mail2 keyword.
Keywords: mail2
Can we really have a relnote that says "Don't try attaching the Netscape home 
page to your messages"?

The blurb:
It seems unclear to me whether this bug requires either of a "developer" or 
"user" release note for Netscape 6 RTM. If anyone feels it does, can they please 
draft one and then nominate with the relnote-user or relnote-devel strings in 
the Status Whiteboard.

Thanks :-)

Gerv
Keywords: relnote2 → relnote

Comment 25

18 years ago
Assign it to fenella@netscape.com
QA Contact: pmock → fenella

Updated

18 years ago
QA Contact: fenella → esther

Updated

18 years ago
Target Milestone: M18 → ---

Updated

17 years ago
QA Contact: esther → trix

Comment 26

17 years ago
could not open audio attachment within mozilla(crushed) but when saved on hard
drive it played fine
Product: MailNews → Core

Updated

11 years ago
Assignee: mscott → nobody
Status: REOPENED → NEW
QA Contact: stephend → backend
(Assignee)

Updated

11 years ago
Product: Core → MailNews Core
I don't see a problem from my horrible attempt to reproduce. but then, it's almost 10 years later, and pages and whatnot have changed.  If someone sees this problem, please clarify with updated testcase and summary.
Status: NEW → RESOLVED
Last Resolved: 19 years ago9 years ago
Keywords: relnote
Priority: P2 → --
Resolution: --- → WORKSFORME
Whiteboard: [nsbeta3-][cut 8/31][nsbeta2-]
You need to log in before you can comment on or make changes to this bug.