Mozilla crash on startup

VERIFIED WORKSFORME

Status

SeaMonkey
General
P3
blocker
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: Sitsofe Wheeler, Assigned: asa)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I tried to start up moz and received the following core dump:
#0  0x4039cdb4 in __libc_read ()
#1  0x40191a7c in __DTOR_END__ ()
#2  0x4034d2f9 in _IO_file_read (fp=0x8051738, buf=0x8055490, size=65536)
    at fileops.c:679
#3  0x4034d15e in _IO_file_xsgetn (fp=0x8051738, data=0x8055490, n=65536)
    at fileops.c:895
#4  0x4034e046 in _IO_sgetn (fp=0x8051738, data=0x8055490, n=65536)
    at genops.c:431
#5  0x403499e4 in _IO_fread (buf=0x8055490, size=1, count=65536, fp=0x8051738)
    at iofread.c:42
#6  0x400c37fd in bufio_Flush ()
#7  0x400c3482 in bufio_Read ()
#8  0x400be512 in nsXPTCStubBase::Sentinel9 ()
#9  0x400be918 in nsXPTCStubBase::Sentinel9 ()
#10 0x400bf286 in nsXPTCStubBase::Sentinel9 ()
#11 0x400bf81e in nsXPTCStubBase::Sentinel9 ()
#12 0x400c0028 in NR_RegAddKeyRaw ()
#13 0x400a8440 in nsRegistry::AddSubtreeRaw ()
#14 0x400a430e in nsComponentManagerImpl::AddComponentToRegistry ()
#15 0x400a3e11 in nsComponentManagerImpl::RegisterComponentCommon ()
#16 0x400a3b8d in nsComponentManagerImpl::RegisterComponentWithType ()
#17 0x400a3c0c in nsComponentManagerImpl::RegisterComponentSpec ()
#18 0x400a57df in nsGenericModule::RegisterSelf ()
---Type <return> to continue, or q <return> to quit---
#19 0x400a653b in nsNativeComponentLoader::SelfRegisterDll ()
#20 0x400a6dd0 in nsNativeComponentLoader::AutoRegisterComponent ()
#21 0x400a6199 in nsNativeComponentLoader::RegisterComponentsInDir ()
#22 0x400a60bd in nsNativeComponentLoader::AutoRegisterComponents ()
#23 0x400a4aa5 in nsComponentManagerImpl::AutoRegister ()
#24 0x400a960e in nsComponentManager::AutoRegister ()
#25 0x4047965e in NSGetModule ()
#26 0x804acb9 in JS_PushArguments ()
#27 0x804b4b3 in JS_PushArguments ()
#28 0x403101eb in __libc_start_main (main=0x804b330 <JS_PushArguments+7360>,
    argc=1, argv=0xbffffa64, init=0x8049330 <_init>, fini=0x804bfd4 <_fini>,
    rtld_fini=0x4000a610 <_dl_fini>, stack_end=0xbffffa5c)
    at ../sysdeps/generic/libc-start.c:90

Sorry I can't provide more information - I don't fully understand core dumps...
I think this took down the whole OS too - not just X. I had to switch the whole
computer off becuase it wouldn't respond to reset keys.

Build id: 20000506 Linux

Comment 1

18 years ago
win32 build 2000050609 on w95 dumps, too (but didn't harm other apps or the 
os):

MOZILLA caused an invalid page fault in
module NKHTTP.DLL at 014f:00bd384a.
Registers:
EAX=08244c8b CS=014f EIP=00bd384a EFLGS=00010246
EBX=0089b600 SS=0157 ESP=0068eaf8 EBP=0068eb40
ECX=0089e3d0 DS=0157 ESI=00bd349d FS=3c67
EDX=00000002 ES=0157 EDI=00000000 GS=0000
Bytes at CS:EIP:
ff 10 8b f8 8b 06 56 ff 50 08 8b c7 5f 5e 5b c2 
Stack dump:
00bd349d 602d3a58 0089b600 80000000 0068eba4 00000000 60cb236f 00000000 
602d3a58 0068eba4 60cb06b1 0089b5c0 00000000 602d3a58 0068eba4 00000000 

borland's compiler states fault 0xBE384A, read of address 0x8244C8B (mov eax, 
[esi] ... call [eax])

Comment 2

18 years ago
I can confirm win32 crash on startup
build is nightly from May 7 2000.
Running Win95 behind ms proxy.

MOZILLA caused an invalid page fault in
module NKHTTP.DLL at 014f:00e6384a.
Registers:
EAX=08244c8b CS=014f EIP=00e6384a EFLGS=00010246
EBX=00d60740 SS=0157 ESP=0068eaf8 EBP=0068eb40
ECX=00d62d20 DS=0157 ESI=00e6349d FS=4d37
EDX=0000000b ES=0157 EDI=00000000 GS=0000
Bytes at CS:EIP:
ff 10 8b f8 8b 06 56 ff 50 08 8b c7 5f 5e 5b c2 
Stack dump:
00e6349d 602d3a58 00d60740 80000000 0068eba4 00000000 60cb236f 00000000 
602d3a58 0068eba4 60cb06b1 00d60950 00000000 602d3a58 0068eba4 00000000 

Comment 3

18 years ago
Just tried nightly build from 8 May - it's still crashing:

MOZILLA caused an invalid page fault in
module NKHTTP.DLL at 014f:606c384a.
Registers:
EAX=08244c8b CS=014f EIP=606c384a EFLGS=00010246
EBX=00cd0360 SS=0157 ESP=0068eaf8 EBP=0068eb40
ECX=00cd2940 DS=0157 ESI=606c349d FS=5e37
EDX=0000000b ES=0157 EDI=00000000 GS=0000
Bytes at CS:EIP:
ff 10 8b f8 8b 06 56 ff 50 08 8b c7 5f 5e 5b c2 
Stack dump:
606c349d 602d3a58 00cd0360 80000000 0068eba4 00000000 60cb236f 00000000 
602d3a58 0068eba4 60cb06b1 00cd0570 00000000 602d3a58 0068eba4 00000000 
(Assignee)

Comment 4

18 years ago
Have you all removed all traces of previous builds (including profiles, 
mozregistry.dat, etc).  I cannot reproduce this with 050808 build under NT

Comment 5

18 years ago
I kept M15 because otherwise I cant set my proxy settings in Mozilla (it 
crashes. If I install M15 I can set my proxy settings in that and the latest 
builds recognize them.

Comment 6

18 years ago
Okay, deleted all traces of prior versions, now no problem launching. (Just 
crashes when I try to input proxy server settings)
(Assignee)

Comment 7

18 years ago
sitsofe@yahoo.com (Sitsofe Wheeler) are you still having this problem with 
current builds?

Comment 8

18 years ago
Adding crash keyword.
Keywords: crash
(Reporter)

Comment 9

18 years ago
I no longer see this crash. Marking worksforme.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 10

18 years ago
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.