Last Comment Bug 384073 - Inconsistent behaviour of Ctrl+/Alt+Return between URL bar and document links
: Inconsistent behaviour of Ctrl+/Alt+Return between URL bar and document links
Status: RESOLVED DUPLICATE of bug 237027
:
Product: Firefox
Classification: Client Software
Component: Keyboard Navigation (show other bugs)
: unspecified
: x86 Windows XP
: -- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Dão Gottwald [:dao]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 15:01 PDT by Kuno Meyer
Modified: 2007-06-11 15:41 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Kuno Meyer 2007-06-11 15:01:09 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070607 Minefield/3.0a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070607 Minefield/3.0a6pre

Firefox has focus-dependant shortcuts for loading a link/URL in a new tab
- from the URL bar: use Alt+Return
- from a selected link in the document: use Ctrl+Return

This is incosistent behaviour and it is not obvious why different shortcuts apply for the same task.

Proposal:
I suggest to use Ctrl+Return *everywhere* to open a new tab, thus including the URL bar. This use of Ctrl would conform to Ctrl+LeftClick for opening a new Tab with the mouse.

The current use of Ctrl+Return in the URL bar (the loading of <www.*.com>) is an unnecessary feature that adds little value. It could be left away. (I.e. it is not obvious, why the .com TLD should get superior treatment over .org/.net or any other country-specific TLD.)


Reproducible: Always
Comment 1 Jesse Ruderman 2007-06-11 15:41:54 PDT

*** This bug has been marked as a duplicate of bug 237027 ***

Note You need to log in before you can comment on or make changes to this bug.