Return value nonsense in nsIComponentRegistrar comments

RESOLVED DUPLICATE of bug 331566

Status

()

Core
XPCOM
--
trivial
RESOLVED DUPLICATE of bug 331566
11 years ago
4 years ago

People

(Reporter: Wladimir Palant, Assigned: Wladimir Palant)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
Created attachment 268064 [details] [diff] [review]
Proposed patch

Several void methods in nsIComponentRegistrar are documented as:

  @return NS_OK     Unregistration was successful.
          NS_ERROR* Method failure.

That's nonsense, these methods don't return anything, and this documentation of error conditions applies to all XPCOM methods equally. So this should simply be removed.
Attachment #268064 - Flags: superreview?(darin.moz)
Attachment #268064 - Flags: review?(darin.moz)

Comment 1

6 years ago
Comment on attachment 268064 [details] [diff] [review]
Proposed patch

trev if you're still interested, this is bitrotten but at least part is still valid and you're welcome to push it ;-)
Attachment #268064 - Flags: superreview?(darin.moz)
Attachment #268064 - Flags: superreview?
Attachment #268064 - Flags: review?(darin.moz)
Attachment #268064 - Flags: review+

Updated

6 years ago
Attachment #268064 - Flags: superreview?
(Assignee)

Comment 2

4 years ago
This has been resolved in bug 331566 it seems.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 331566
You need to log in before you can comment on or make changes to this bug.