If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

nsPersistentProperties debug spewage from loading start.xhtml for properties on startup

RESOLVED DUPLICATE of bug 386698

Status

Thunderbird
General
--
minor
RESOLVED DUPLICATE of bug 386698
10 years ago
10 years ago

People

(Reporter: Tuukka Tolvanen (sp3000), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
WARNING: the property margin already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property background already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property padding already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property background already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property height already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property font-weight already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property font-size already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property padding already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property }

body[dir already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property background already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property padding already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property background already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property }

body[dir already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property background already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property letter-spacing already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property background already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property }

a already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property background already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property color already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property <li><a href already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property <li><a href already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property <li><a href already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301
WARNING: the property <li><a href already exists
: file /home/tt/src/moz/trunk/mozilla/xpcom/ds/nsPersistentProperties.cpp, line 301

this comes from GetDefaultFromPropertiesFile mailnews.start_page.url chrome://messenger/content/start.xhtml. guess this is roughly the same as bug 378210 comment 5
Forward-duping, since Scott places the blame more precisely (and in another Product, which is always nice).
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 386696
Or, not, given bug 386698. Next time, I'll wait for a fixed one, and dupe to that.
Bug 386698 is a better one to dupe against.
Duplicate of bug: 386698
You need to log in before you can comment on or make changes to this bug.