Runaway JavaScript is not handled properly, UI unresponsive.

RESOLVED DUPLICATE of bug 159909

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 159909
11 years ago
11 years ago

People

(Reporter: Vlad Sukhoy, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 268073 [details]
Testcase for runaway JavaScript stalling the UI.

The attached testcase should be handled as a runaway JavaScript. What happens instead is a total blocking of UI thread on 1.8 and Trunk in Windows, MacOS (The "Unresponsive Script" window may appear but is useless).

Reporting as Unconfirmed, as this is most likely a duplicate of an earlier bug, I just could not figure out which.

Expected results: UI not stalled, JavaScript correctly reported as runaway and the "Unresponsive Script" window functional.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 159909
You need to log in before you can comment on or make changes to this bug.