Closed Bug 384187 Opened 15 years ago Closed 15 years ago

12th June Trunk build is inaccessible in Linux

Categories

(Firefox :: Disability Access, defect)

x86
Linux
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: jdiggs, Assigned: ginnchen+exoracle)

References

(Blocks 1 open bug)

Details

(Keywords: access)

Attachments

(1 file)

Steps to reproduce:

1. Launch the 12th June build of Firefox
2. Launch Accerciser or AT-POKE

Expected results:  You would be able to examine Firefox in Accerciser/AT-POKE

Actual results:  You cannot examine Firefox in Accerciser/AT-POKE
Assignee: nobody → ginn.chen
I cannot reproduce it
reproduced on my box.

related to enable-libxul?
There are three night builds for Linux on 12th June in ftp.mozilla.org/pub/firefox/nightly

One is under folder 2007-06-12-04-trunk/, this one is ok;
The other two are under folder 2007-06-12-07-trunk/ and 2007-06-12-13-trunk/, they're broken.
Yeah, this was just build bustage from the libxul enabling. It should be fixed now.
workaround: export GNOME_ACCESSIBILITY=1 before start firefox
I got NS_ERROR_FACTORY_NOT_REGISTERED 
when trying to get sysPrefService in nsWindow.cpp

sysPrefService is @mozill.org/system-preference-service;1
Err... please disregard my comment 4.
libsystem-pref is not registered.
It was moved from dist/bin/components/libsystem-pref.so to dist/bin/libxul.so.

I've no idea how to make it work again.
Do we need something like Bug 339106?
Attached patch patchSplinter Review
Thank you very much for pointing me there.
Attachment #268324 - Flags: review?(benjamin)
Attachment #268324 - Flags: review?(benjamin) → review+
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.