Labels on the search and location boxes are not Read.

RESOLVED FIXED

Status

()

Firefox
Disability Access
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Tim Keenan, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a6pre) Gecko/20070612 Minefield/3.0a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a6pre) Gecko/20070612 Minefield/3.0a6pre

Screen-readers are not reading the labels associated with the search and location boxs in FF3.  This could be because the labels don't exist.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox 3.
Press ctrl+l

2. If you wish, press tab to get to the search box.
3.
Actual Results:  
You hear the type of field, i.e. edit or edit combo, but not it's name.


Expected Results:  
Same  behavior as FF2.  Upon pressing ctrl+l you should hear "Location" foby the field type.  Pressing ttab should yield "search."

Sorry for the mess.  I'll clean up once I go back to FF2.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
(Reporter)

Updated

11 years ago
Summary: Labels on the search and location boxes are not rad. → Labels on the search and location boxes are not Read.

Updated

11 years ago
Blocks: 368877

Comment 1

11 years ago
Created attachment 268203 [details] [diff] [review]
Fix nsHTMLTextFieldAccessible() so that XUL parent's name is reused for it, 2) Provide nice accessible name for <searchbox> e.g. "Search Google"
Attachment #268203 - Flags: review?

Updated

11 years ago
Attachment #268203 - Flags: review? → review+

Updated

11 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Updated

11 years ago
Attachment #268203 - Flags: review?(mano)
Comment on attachment 268203 [details] [diff] [review]
Fix nsHTMLTextFieldAccessible() so that XUL parent's name is reused for it, 2) Provide nice accessible name for <searchbox> e.g. "Search Google"

I guess... note we didn't do this for the grayed-out text in this field because of engines like "MSN Search"; for the screen-reader case that's still better though.

please add the readonly attribute to your getter, r=me otherwise.
Attachment #268203 - Flags: review?(mano) → review+

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.