"Search in Bookmarks" search field looks much worse on mac than it does on windows

VERIFIED FIXED in Firefox 3 alpha8

Status

()

VERIFIED FIXED
12 years ago
9 years ago

People

(Reporter: moco, Assigned: dietrich)

Tracking

Trunk
Firefox 3 alpha8
x86
Mac OS X
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [places-ui])

Attachments

(4 attachments)

"Search in Bookmarks" search field looks much worse on mac than it does on windows

For example, it is is much taller.

screen shot coming.

I'm wondering if it should look more like the search box in the browser, where the drop down is centered vertically?
Created attachment 268164 [details]
screen shot on mac
Flags: blocking-firefox3?
Created attachment 268249 [details]
how it looks on windows
Created attachment 268250 [details]
a suggestion of where to put the drop down, if we plan on keeping it (center it vertically)
This entire window is due for a pretty major redesign (a thread will start soon in dev.apps.firefox), so we may want to hold off on tweaking the current interface.
re-assign to faaborg so that no one takes this an implements it before we have a redesign.
Assignee: nobody → faaborg+bugzilla

Comment 6

12 years ago
Isn't there suppose to be an icon next to the arrow? Like Thunderbird's search field. 
Flags: blocking-firefox3? → blocking-firefox3+

Updated

11 years ago
Target Milestone: --- → Firefox 3 M8
(Assignee)

Updated

11 years ago
Duplicate of this bug: 387743
(Assignee)

Updated

11 years ago
Whiteboard: [places-ui]
(Assignee)

Comment 8

11 years ago
http://people.mozilla.com/~faaborg/files/granParadisoUI/placesOrganizer_i5WindowLayout.png

per the mockup, we can remove the folder filter drop-arrow altogether.
(Assignee)

Comment 9

11 years ago
Created attachment 277158 [details] [diff] [review]
fix v1

this just removes the filter popup altogether for now. we might hook that functionality back up later via different UI, so i've left the plumbing intact.
Assignee: faaborg+bugzilla → dietrich
Status: NEW → ASSIGNED
Attachment #277158 - Flags: review?(sspitzer)
Comment on attachment 277158 [details] [diff] [review]
fix v1

what about onPlaceSelected() and other code in places.js?  

If we remove this from places.xul, lots of stuff will break.
Attachment #277158 - Flags: review?(sspitzer)
To put the removal of the folder filter drop down into context: the plan is to display a scope bar control when the user performs a search:

http://people.mozilla.com/~faaborg/files/granParadisoUI/placesSearch_i4AdvancedSearch.png

(note that this mockup isn't final)

We will still need to know what folder the user was in, because that will be one of the options in the scope bar.
Comment on attachment 277158 [details] [diff] [review]
fix v1

r=sspitzer, dietrich explained over irc.

do we have a spin off bug to track faaborg's "scope bar"?
Attachment #277158 - Flags: review+
(Assignee)

Comment 13

11 years ago
(In reply to comment #12)
> (From update of attachment 277158 [details] [diff] [review])
> r=sspitzer, dietrich explained over irc.
> 
> do we have a spin off bug to track faaborg's "scope bar"?
> 

no, that mockup isn't final yet. the search builder is currently bug 387744.
(Assignee)

Comment 14

11 years ago
Checking in browser/components/places/content/places.xul;
/cvsroot/mozilla/browser/components/places/content/places.xul,v  <--  places.xul
new revision: 1.77; previous revision: 1.76
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
verified with - Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a8pre) Gecko/2007091304 Minefield/3.0a8pre
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.