If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<marquee> should not inherit text-indent (causes incorrect line break)

RESOLVED FIXED

Status

()

Core
Layout: Block and Inline
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: j.j., Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070612 Minefield/3.0a6pre
Build Identifier: 

<marquee> inside blocks with text-indent behaves unexpected and different than IE.
For example, there is an useless line break.

marquee { text-indent: 0; }   in html.css would fix it.

Reproducible: Always

Steps to Reproduce:
See Testcase
Actual Results:  
Line breaks inside <marquee>

Expected Results:  
No line break

<http://www.w3.org/TR/2006/WD-CSS21-20061106/text.html#indentation-prop>
notes this:
"Since the 'text-indent' property inherits, when specified on a block element, it will affect descendent inline-block elements. For this reason, it is often wise to specify 'text-indent: 0' on elements that are specified 'display:inline-block'."
(Reporter)

Comment 1

10 years ago
Created attachment 268228 [details]
testcase
(Reporter)

Updated

10 years ago
Blocks: 163504
Keywords: regression, testcase
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 268229 [details]
testcase2

This testcase shows that IE uses the text-indent.
But it doesn't add a weird line-break like Firefox is doing in current trunk builds.
Also behavior=alternate is behaving differently in Firefox.
This would probably be fixed when bug 368155 gets fixed.
Depends on: 368155

Updated

10 years ago
Version: unspecified → Trunk
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> This would probably be fixed when bug 368155 gets fixed.

WFM now with bug 368155 fixed. 
(But there is still the issue with behavior=altermate, is it worth to file a bug about?)

(In reply to comment #4)
> WFM now with bug 368155 fixed.

Yeah, this is now fixed by bug 368155.

> (But there is still the issue with behavior=altermate, is it worth to file a
> bug about?)

Sure, file a new bug on that. Thanks.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Flags: in-testsuite?
(Reporter)

Comment 6

10 years ago
(In reply to comment #4)
> WFM now with bug 368155 fixed. 
> (But there is still the issue with behavior=altermate, is it worth to file a
> bug about?)

...furthermore the first marquee of testcase 2 doesn't scroll over the complete width.

Filed bug 386468 about these issues.

You need to log in before you can comment on or make changes to this bug.