QuickSearch Includes the shortcut in the query field

RESOLVED INVALID

Status

()

Firefox
Search
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Myzar, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a6pre) Gecko/20070613 Turborhino/3.0a6pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a6pre) Gecko/20070613 Turborhino/3.0a6pre

I like to use quicksearch to google around example i write in the url g something. 
In latest trunk the g shortcut is included in example:

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=g+something

Reproducible: Always

Steps to Reproduce:
1. In the url bar type g something
2. google will load with this url http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=g+something
3. You can see that is searching for g something
Actual Results:  
google is searching for g something

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=g+something

Expected Results:  
google should search for something

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=something

I can reproduce this with a clean profile and in safemode too.
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
We removed the default Google bookmark keyword a while ago, in bug 348165 (and it looks like the keyword was "google", not "g"). If you want it you'll have to add it manually, using "Add a keyword for this search".

For unrecognized keywords, we just treat the entire string as the query terms, and we default to using Google for location bar keyword lookup, so that's why you get the behavior you do. You could alternatively just omit the "g" keyword and get essentially the same result (though we default to a variant of "I'm Feeling Lucky" that sometimes gives you results, and other times forwards you directly to the first result, when it's confident enough that it got the right match).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.