Closed Bug 384312 Opened 12 years ago Closed 11 years ago

File Upload PPT file exposes text/html MIME Type

Categories

(Firefox :: File Handling, defect, major)

2.0 Branch
x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 306471

People

(Reporter: coeurs, Unassigned)

Details

(Keywords: qawanted, regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Previous versions (2.0.0.3) upload PPT properly, for some reason 2.0.0.4 uploads PPT files as text/html or "unknown" type to the receiving system (which then defaults to text/html).  This is bad as we are getting corrupt file associations in document repositories.

Reproducible: Always

Steps to Reproduce:
1. Goto a file upload / document repository
2. Select a .ppt file to upload
3. check the associated type on the server (jsp smart upload or other utility recieves wrong info from Firefox client sending file information).
Actual Results:  
File was saved to server with proper info except for contentType and contentSubType properties.

Expected Results:  
Application/vng.ms-powerpoint
Keywords: qawanted, regression
Version: unspecified → 2.0 Branch
The reason is once you display a .ppt with an incorrect type, we'll remember it.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373621
Duplicate of bug: 306471
You need to log in before you can comment on or make changes to this bug.