Closed Bug 384322 Opened 13 years ago Closed 13 years ago

Website Layout broken: softpedia.com

Categories

(Core :: Layout, defect, P2)

x86
Windows XP
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: mulder2, Assigned: cpearce)

References

()

Details

(Keywords: regression, testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070613 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070613 Firefox/2.0.0.4

The following web-site is displayed distorted in SeaMonkey:
http://www.softpedia.com/

The website layout is broken, as you can see on the icons on the top of that page. Also the search form at the right side is broken. Furthermore the vertical scrollbar is MUCH to long.

This website is displayed properly in latest official Firefox release as well as in the latest Opera browser.

See this screenshot for details, today's build shows the same result:
http://img444.imageshack.us/img444/5511/filemonkeypedialv8.png


Reproducible: Always

Steps to Reproduce:
1. Run SeaMonkey 2.0a
2. Enter "http://www.softpedia.com/" into the address bar and press <Enter>
3. See yourself!
Actual Results:  
The website is displayed distorted. The layout is obviously broken!
http://img444.imageshack.us/img444/5511/filemonkeypedialv8.png

Expected Results:  
The website should be displayed properly. It should be displayed as it is displayed in all other browsers I tested (Firefox, Opera, etc.)
Assignee: general → nobody
Component: General → Layout
Product: Mozilla Application Suite → Core
QA Contact: general → layout
Version: unspecified → Trunk
-->NEW

im seeing this one with

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a9pre) Gecko/2007110522 Minefield/3.0a9pre ID:2007110522
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.9?
Keywords: qawanted
Summary: Website Layout broken: softpedia.com (and maybe others) → Website Layout broken: softpedia.com
regressed from reflow branch landing.
Keywords: regression
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
A reduced testcase would be awesome.
This test case shows what's happening; when a table doesn't have enough room to render a run of images, which don't have spaces between them, FF2, IE7, Safari and Opera9 all stretch the table to fit the images on one row, whereas Minefield is wrapping them onto two rows as if they had spaces in between them.
Assignee: nobody → chris
Status: NEW → ASSIGNED
Keywords: qawantedtestcase
fwiw, www.softpedia no had the manifestation  this bug, but testcase still renders with the wrapping bug.

i think this was already fixed (by bug 368554 ?)

Well, it was fixed, but now the second example of Testcase 1 doesn't wrap either, which it used to do.
It also does wrap in Opera9 and IE, so it seems like a serious problem.
Actually that looks like a bug in min-width calculation --- we do break between the images with markup like this:

<div style="width:0"><img width="50" height="50"> <img width="50" height="50"></div>

So it's not related to 405577 I guess.
Fixed, including Testcase 1 thanks to checking for bug 407227, closing bug.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Flags: in-testsuite?
verified fixed using Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b3pre) Gecko/2008010104 Minefield/3.0b3pre ID:2008010104 and the testcase and the softpedia.com website 

- Verified fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.