attached image cuts off in Vertical view

RESOLVED INCOMPLETE

Status

Thunderbird
Mail Window Front End
RESOLVED INCOMPLETE
11 years ago
8 years ago

People

(Reporter: dave white, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-08-28)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

if I am sent an inline jpg it gets cut off where the image in the viewer meets the divider between the main message pane and the little area that shows icons of the attached images.  If I try to view the image in its own message window, its still cutoff.  Meanwhile, if I look at the same message in webmail, its all there.  I've taken a screenshot here http://spacehotel.com/thunderbird/thunderbird_image_bug.jpg  The image looks fine until I scroll down and notice that its cut off right there.  Here is the beginning of the source for the attached image

------_=_NextPart_001_01C7AEBE.6A2DF2AE
Content-Type: image/jpeg;
	name="E3_invitation_v2.JPG"
Content-Transfer-Encoding: base64
Content-Description: E3_invitation_v2.JPG
Content-Disposition: attachment;
	filename="E3_invitation_v2.JPG"

/9j/4AAQSkZJRgABAQEASABIAAD/4RtgRXhpZgAASUkqAAgAAAAHABIBAwABAAAAAQB6fBoBBQAB

Reproducible: Sometimes

Steps to Reproduce:
1. Receive an HTML email with attached JPG image
2. View email in Vertical view.
3. If image is larger than the pane, it will be cut off at the bottom where it reaches the border.

Comment 1

11 years ago
Uh.. the scrollbars vertical and horizontal appear, all you need is to scroll. 

Auto-zoom (like in firefox) has been fixed on trunk i believe.

Comment 2

11 years ago
Reporter sent me: "Its not the scrollbars that are the bug.  Its the image.  Notice the image is not fully rendered, rendering cut off at the bottom border.  I scrolled up to show that."

(please keep the comments in bugzilla)

Comment 3

11 years ago
Hi,

Is auto-zoom on the roadmap ?
I didn't find a feature request concerning this point.

Thanks.

Comment 4

10 years ago
I'm suffering the same bug, no matter what display mode I have (wide, vertical OR classic) ... I'm connected via IMAP to two different servers, and both load only part of an inline image. Also seems to affect message bodies in Simple and Original HTML.

The only way to view the whole image is to exit Thunderbird and relaunch. Even trying to save the image only saves a partial image.

Mac OS 10.5
Thunderbird 2.0.0.12

Thunderbird Add-ons installed are:
Lightning, Provider for Google Calendar, Growl Notifications, and Talkback.
(In reply to comment #4)
>(a) IMAP, both load only part of an inline image.
>(b) The only way to view the whole image is to exit Thunderbird and relaunch.
>(c) Thunderbird 2.0.0.12

To Ryan Vanderzanden:
  
Bug 386514 was fixed by Tb 2.0.0.5, and Bug 405440 was fixed by Tb 2.0.0.12.
So (a)&(c) sounds phenomenon of Bug 390795(for non MS Exchange) or Bug 92111(for MS Exchange). But if Bug 390795 or Bug 92111, I think (b) can not be explained. 
Get IMAP protocol log and check protocol level flow.
See Bug 402793 comment #1 for getting NSPR log.
If new problem, open separate bug instead of adding comment to this unclear bug, after search bugzilla.mozilla.org well for already fixed/opened/dupe'ed bug. 

(In reply to comment #0)
> Gecko/20070515 Firefox/2.0.0.4

To dave white(bug opener):

Tb's version was 2.0.0.4 too when bug was opened?
POP3? IMAP? If IMAP, "offline use"=OFF? "offline use"=ON? (not "offline mode")
Problem still occurs with latest release of Tb? (as of today, Tb 2.0.0.12)
Get IMAP protocol log.
Dup of Bug 386514? Or Dup of Bug 405440? Or Dup of Bug 390795(or Bug 92111)? Or different or new problem?
Reporter, does the issue still occur in the latest supported 2.0.0.x / Shredder trunk nightlies?

(1.5.0.x is now end-of-life and the latest supported 2.0.0.x is 2.0.0.16)

Please answer comment #5 as well.
Whiteboard: closeme 2008-08-28
RESO INCO per lack of response to the last question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.